SharePoint Foundation 2010 on SBS 2008

I am installing SharePoint Foundation Server 2010 on a SBS 2008 machine in order to upgrade from WSS 3.0 - SP2) and I am following these detailed instructions:

http://technet.microsoft.com/en-us/library/ff959273(WS.10,printer).aspx#BKMK_Step10

I’m running into issues at step # 6.  Instead of installing SQL Server 2008 SP1, I instead opted to go with SQL Server 2008 R2 – (64bit) in order to have access to a 10GB content database, instead of 4GB.  I installed pretty much along these lines:

http://blogs.msdn.com/b/petersad/archive/2009/11/13/how-to-install-sql-server-2008-r2-express-edition-november-ctp.aspx

SQL Server 2008 R2 is now up and running on SBS 2008 and I created an instance called “Express” as directed to do so (using SQL Server Management Studio).  

In step 6:(1) I’m not too sure how to:

“Make sure that the new instance of SQL Server 2008 Express is running as a domain account” (??)

In step 6: (2) – I ran the SharePoint Products Preparation tool again and all went well. No errors there.

In step 6: (3) – Installing SharePoint Foundation 2010 in Farm Mode – this is where the issue starts.   I specify the Server Name\Database instance name as instructed and put in credentials and then upon clicking OK, I get the following error message:

“The database name located at the specified database server has in incorrect collation. Rebuild the database with the Latin1_General_CI_AS_KS_WS collation or create a new database using the Latin1_General_CI_AS_KS_WS collation”.

I neither know how to rebuild this newly created database, or how to create a new one without the same error appearing again and again. I’ve gone into the SQL Server Studio and have right-clicked and deleted the database and recreated it, but to no avail.  

I know virtually nothing about SQL Server – I’m an Access 2007 guy.   Any help is greatly appreciated.  
LVL 1
BAmillerAsked:
Who is Participating?
 
RipinConnect With a Mentor Commented:
that's the one, just delete logs and primary data file, dont delete anything else!!!
0
 
RipinCommented:
there is a dirty way of doing that.
http://blog.sqlauthority.com/2009/10/19/sql-server-change-collation-of-database-column-t-sql-script-consolidating-collations-extention-script/

You could select default collation when you install SQL server. Setup /QUIET /ACTION=REBUILDDATABASE /INSTANCENAME=InstanceName
/SQLSYSADMINACCOUNTS=accounts /[ SAPWD= StrongPassword ]
/SQLCOLLATION=CollationName

Setup /QUIET /ACTION=REBUILDDATABASE /INSTANCENAME=Express /SQLSYSADMINACCOUNTS=DOMAIN\SQLAccount /SAPWD=Pass@word1 /SQLCOLLATION=Latin1_General_CI_AS_KS_WS should do the trick.

And that domain account is just account in your AD (DOMAIN\USERNAME) dont use local or network accounts.
0
 
BAmillerAuthor Commented:
Hi Ripin;

Thanks for the info. . . I'm perusing your link at your web site and this is way over my head!  As I mentioned, I know NOTHING about SQL Server!  I'm an Access 2007 guy.  I'm just trying to get SharePoint Foundation Server installed on SBS 2008 per the TechNet article and they did not discuss in any detail the steps to properly install SQL Server -- so, I'm just using most of the "default" settings in the wizard.

I am looking at your proposed solution above -- where exactly do I execute this?  Do I run this as an SQL Query in Management Studio?  Or, is this a script that needs to be run from PowerShell? Or, elsewhere?   I'm lost. . . .
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
RipinCommented:
Just run setup from cmd (Command prompt) and install sql-server again, then run SP Config wizard to create DB and so on.

if using first (the dirty way) execute scripts on Management studio, query builder.
There is no good reason to mess with SP DB's, so when you have the possibility to install SQL again, do that.

Hope this helps...
0
 
RipinCommented:
By the way, what is your servers default locale? If you can change that before install SQL-Server then installation uses that charester set and collation settings.
0
 
BAmillerAuthor Commented:
Not sure what the locale is for the SQL Server -- how do I find that out?   I pretty much used the "default" settings when running the setup Wizard on SBS-2008.  

I did go into Mgmt. Studio and I RIGHT-CLICKED on both "Master" database and "Express" database, and went to Properties, but I can't see the "locale" settings anywhere.  Is that an AD locale?   Not sure exactly how to find that out.   I will try the setup from the cmd prompt and see what happens. . . . Thanks!
0
 
BAmillerAuthor Commented:
One more thing, when checking Properties by Right-clicking both "Master" and "Express" databases, then looking at Extended Properties:

The Master database has a collation setting of:  SQL_Latin1_General_CP1_CI_AS

whereas

The Express database has a collation setting of: Latin1_General_CI_AI_KS_WS

Does that mean anything to you?  
0
 
RipinCommented:
Collation on master is that what have to be Latin1_General_CI_AS_KS_WS. That is SP demand.
0
 
BAmillerAuthor Commented:
Hi again Ripin;

Thanks for all of your help and patience so far! But I'm just lost here . . .

I open a command-prompt on the SBS-2008 server with elevated Admin Privileges and ran the following command at the C:\ prompt

Setup /QUIET /ACTION=REBUILDDATABASE /INSTANCENAME=Express /SQLSYSADMINACCOUNTS=DOMAIN\SQLAccount /SAPWD=Pass@word1 /SQLCOLLATION=Latin1_General_CI_AS_KS_WS

and got an "invalid command" message, thus I assume that this has to be run from the SQL Server 2008 installation directory.    Problem is, I can't find the right path!  

On my C:\ drive the Server, I have both "Program" and "Program (x86)" directories (64 / 32 bit, I suppose).

Both of those directories have "Microsoft SQL Server" sub-directories in them, and upon drilling down, they both contain 80/90/100/ subdirectories.  Beyond that, they then both branch out into additional  folders.  I have no idea of exactly what path I need to be at when running this script!

Can you help me with that?

Also, still trying to figure out what "locale" SQL Server 2008 was installed into -- how can I find that out?

Thank you again!  


 
0
 
RipinCommented:
You have to run that command against setup file witch you have downloaded or have on cd, flash drive etc. First from the command prompt cd to thet directory where setup file is and then run it...

locale = Control Panel >> Regional Settings >> Default locale
0
 
BAmillerAuthor Commented:
Hey Ripen;

I think I am making some progress here.  I've been working on this all day today, but seem to making some forward progress, but still hitting errors.

I FINALLY got the install script noted above to work. First time around, I ran it exactly "as is" from an elevated command prompt on the SBS 2008 Server, and it would not work (domain name and SQL Account name and a valid SA password were required).  I changed the script to add those credentials and ran it again.  It ran for 3 - 4 minutes then returned a line at the end that read:

E:\>/SQLCOLLATION=Latin1_General_CI_AS_KS_WS

I suppose that means that this worked?  (see attached screen shot from Command Prompt window)

Next, I then ran the SharePoint Foundation Server 2010 Configuration Wizard again and went through the steps to create a database called "Express" and then I accepted all other default settings along the way. All seemed to be going great, then the new error occurred (see screen shot of message).

What do you suggest I do now in response to this message?   I'm lost, as usual.  Getting in over my head I think . . .  : )

Thanks!
SQL2008Setup.txt
Setup-Error.png
0
 
BAmillerAuthor Commented:
btw, forgot to mention, I did save the log file noted in the error link above, but its a 7.1 MB TEXT FILE!  Its huge with what appears to be a few thousand lines in it.  If you need to look at that, let me know and I'll find a way to email it to you privately. . .

Thanks
0
 
RipinCommented:
You have that database allready. You have to delete it from SQL management console. Then install SP. There can't be two same name database...
0
 
BAmillerAuthor Commented:
I've done some poking around and not exactly sure how to find the "Express" Database and/or how to get rid of it.  See attached screen shots.

The first one shows the view from within SQL Server Management Studio -- there is no database listed there called "Express".

Next, I started poking around in C:\Program Files\Microsoft SQL Server\MSSQL.10.EXPRESS\MSSQL\DATA:

and found a Primary Data File and a corresponding log file called "Express" -- is it OK to just delete those?  Is that what I'm looking for?  

Again -- Access 2007 guy here . . . I don't know jack about SQL Server -- thanks for your continued support!
SQL.png
0
 
BAmillerAuthor Commented:
opps! forgot to add the second image.  Thanks,
Studio.png
0
 
BAmillerAuthor Commented:
Hi Ripin;

Sorry for the delay between posts -- I was out on Business for most of last week.  Work comes first!

I deleted the "Express" Database and log as instructed, then re-ran the SharePoint Configuration Wizard and now have a successful install of SharePoint Foundation 2010 running on SBS-2008.  Ya-hoo!

Thank you so much for all your help throughout this process - could not have done it without your guideline (and patience!).

All points are being awarded accordingly.

Thanks again.
Success.png
0
 
BAmillerAuthor Commented:
GREAT SUPPORT!  Thank you
0
 
BAmillerAuthor Commented:
To anyone considering installing SharePoint 2010 on SBS-2008, I have one word for you . . .

WAIT!

Small Business Server 7 "Aurora" is right around the corner and it includes:

Server 2008 R2 code base
Exchange Server 2010
SharePoint Foundation Server 2010

plus lots of other tweaks right out of the box.   I'm testing  the "Preview" version in the lab and I must say it looks very nice!

Very well done thus far and the finished code is sure to be a major hit in the SBS Community.

Don't go through all the heartache of trying to fanangle SharePoint 2010 onto SBS 2008 when you can have it all in SBS-7 soon!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.