Solved

Exchange over HTTP  on SBS 2003

Posted on 2010-09-20
29
1,750 Views
Last Modified: 2012-05-10
Hi there,

I currently use Exchange over HTTP for a number of businesses which work fine. I'm trying to set it up for another account and it refuses to connect.

What I do is enter the server name i.e. server.domain.local, enter my username, then in connection enter the URL of the OWA (i.e. https://domain.domain.com) and select basic authentication.

I get prompted for a username and password but whatever I put the machine doesn't recognise, I know the username / password are correct as if I login to OWA https://domain.domain.com/exchange it works fine!

Any help much appreciated!!

M
0
Comment
Question by:mattstannard
  • 13
  • 13
  • +1
29 Comments
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 33714639
Make sure you have the correct web address - RPC of HTTP is different from RPC over HTTPS - you say you're using HTTP but you're specifying HTTPS.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33714651
Are you using a 3rd party SSL certificate or the SBS self-issued one?
0
 

Author Comment

by:mattstannard
ID: 33714678
Hi,

Thank you both.

I am trying to connect to the https:// service, I know it works as if I go there in my browser and login with my domain username / password I get in fine.

On the default website, what should the directory security / ip restrictions be?

I am using a 3rd party SSL certificate, again that works fine with OWA.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33714694
In Outlook are you typing in https:// or just name.domain.com?  It should just be name.domain.com for the RPC part.
RPC Virtual Directory:
Auth = Integrated & Basic
IP Restrictions = Granted Access
SSL = Require Secure Channel & Require 128-bit
Exchange Virtual Directory:
Auth = Integrated & Basic
IP Restrictions = Granted Access
SSL = Require Secure Channel & Require 128-bit
0
 

Author Comment

by:mattstannard
ID: 33714731
Thanks you,

What I put is as follows:

Server: servername.domain.local
Username: Matt Stannard

Click More Settings, Connection, Tick to connect to Microsoft Exchange using HTTP

in the https:// box I put the servers external domain name (if I go to it and login I see the Welcome to Windows SBS 2003 website)

Select the "Basic Authentication" and tick Slow / Fast Networks as I always want HTTP.

I get a logon prompt, I enter my username mstannard and password doesn't work, so I try domain\mstannard and password doesnt work.




0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33714757
Have you tried with NTL authentication?
Are you filling in the "Only connect to proxy server that have the principal name in their certificate" and entering "msstd:name.domain.com" in that box?
0
 

Author Comment

by:mattstannard
ID: 33714788
Hi Alan,

Just did, didn't seem to make any difference whatsoever.

So strange as on my other HTTP exchange accounts they all work fine!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33714793
Who issued the SSL certificate and does the client you are having problems have them as a trusted provider?
0
 

Author Comment

by:mattstannard
ID: 33714910
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715059
Cert looks fine.
If you browse to the URL via IE that you posted on the client with the problem - does it trust the site?
 
0
 

Author Comment

by:mattstannard
ID: 33715100
Thanks Alan,

Yes - its my own laptop lol! But any machine I try and setup this way has had this issue and I can't figure out why its any different.


0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715130
Can you just put in the server name not servername.domain.local as the servername please and try again.
0
 

Author Comment

by:mattstannard
ID: 33715159
Just to get this right, use server.domain.com in the server in the Mail Account setup, just tried that still doesn't like it.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715209
When entering the server / username - please enter just server, not server.domain.local e.g., server01 instead of server01.internaldomain.local
When entering the HTTPS part, you need to use exchange.yourdomain.com plus msstd:exchange.yourdomain.com
Hopefully that should work.
When entering username / password when prompted, enter domain\username and password.
Domain\username is not internaldomain.local\username, just domain\username.
Sorry if this is teaching you to suck eggs here : )
0
Are end users causing IT problems again?

You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

 

Author Comment

by:mattstannard
ID: 33715258
Hey,

You're not at all, if anything you are proving my own sanity.

Just tried that, made no difference, is there a way to reset the IIS setup, i.e. remove it an reinstall it to see if that helps?

M
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715325
Click on Start, Run {type} inetcpl.cpl {press enter}
Click on the Advanced Tab and click on the Restore Advanced Settings and Reset buttons.
That should take IE back to default settings.
Do you have Firewall / Anti-Virus software on your laptop that might be blocking the comms?
0
 
LVL 2

Expert Comment

by:ksksilva
ID: 33715353
This is similar to a issue I had when I tried to setup RWW over HTTPS through TMG. OWA seems working fine but but Remote Desktop over the web never work out. Assuming you're accessing the SBS through a firewall (Eg: ISA or TMG) I do hope attached file will be useful for you.

Please note attached articles is written by different person and being published in the Technet.


Deploying-ISA-2006-with-Windows-.doc
0
 

Author Comment

by:mattstannard
ID: 33715381
Thank you for this, I can connect to Remote Web Workplace, can use RDP.

The machine isn't running ISA but I'll have a read.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715417
Is your laptop up-to-date with Windows Updates etc?  Manual check - not just automatic check.
0
 

Author Comment

by:mattstannard
ID: 33715588
Hi Alan,

Yep - there is one Office update I'll try that.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715597
What about my Firewall / Anti-virus question earlier?  Anything installed?
0
 

Author Comment

by:mattstannard
ID: 33715920
Hi Alan,

On my machine I've got AVG, although as I said I have three other MS Exchange setups on my laptop all of those work fine.

The server which doesn't work is behind a DrayTek 2820, port forwarding 443 / 80 to that box, perhaps it needs to forward some other ports although can't think what.

Just checked Exchange Version to, looks like its SP2 -  6.5.7638.1

M
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33715966
Only HTTPS is required.
Does the Draytek use HTTPS management remotely for the router?
You might want to check that it isn't and that HTTPS isn't going to the Router and not being passed through it as you are expecting.
0
 

Author Comment

by:mattstannard
ID: 33715999
Hi Alan,

A good point, but OWA works fine https://exchange.mydomain.org/exchange and https://exchange.mydomain.org/ both go to the server :-(

M
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 33716027
Okay - that's a valid point!
Do you know that it is setup properly on the server you can't reach?
Can you run the RPC over HTTP test at https://testexchangeconnectivity.com and see what results you get.
0
 

Author Comment

by:mattstannard
ID: 33716092
Ohhh! That's a great tool!!

I got:

Testing Http Authentication Methods for URL https://exchange.mydomain.org/rpc/rpcproxy.dll
The HTTP authentication test failed.
Tell me more about this issue and how to resolve it

Additional Details
Initial Anonymous HTTP(s) request did not fail but Anonymous is not a supported Authentication Method for this scenario
0
 

Author Closing Comment

by:mattstannard
ID: 33716137
Yep, permissions issue on the RPC directory, followed the instructions worked like a charm thanks!!!!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33716308
Excellent - well done.
I also obscured your domain name in your last post but one.
Alan
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now