Solved

Slow backups on Server 2008 SP2 standard

Posted on 2010-09-20
11
2,137 Views
Last Modified: 2013-12-01
Hi experts

We have a server running windows server 2008 SP2 standard which has MS SQL server 2005 installed with some small SQL databases. Our backups are intermittently taking a long time to run. And there doesn’t appear to be any particular pattern to the issue.

We are using the Symantec backup exec system recover 2010 software with a scheduled backup at 9pm in the evening to image all the drives and often the backup doesn’t finish until 11:00am or even later in the following day. Even if we just backup the system drive which doesn’t have much data apart from the operating system then the backup still doesn’t finish until 2 -2:30am in the morning.

We have also tried to use the inbuilt windows backup software but backups still sometimes take a long time to run. If we reboot the server and then the next scheduled backup runs faster (backups usually finish of all drives by 2-2:30am in the morning which is what we would expect) but then a few days later we will get the same slow backup issue. When the backups are running the server’s memory usage is very high (often 95%) but the processor usage is low (around 5%) and it looks like SQL is using most of the memory so perhaps a software configuration on SQL server 2005 is the problem?. All disks have plenty of free disk space.

The below shows the servers disk allocation:

#1.1 C      SYSTEM DISK      Size: 50Gb
      W2008 Operating system      
      Swap space      
            
#1.2 E      Applications      Size: 415Gb
      SQL      
      SAP      
            
#2 F      OtherData      Size: 465Gb
            

Any help on how to resolve this issue would be great.

Kevin
0
Comment
Question by:kevin1983
  • 6
  • 4
11 Comments
 
LVL 7

Expert Comment

by:rashmi_vaghela
ID: 33715150
0
 

Author Comment

by:kevin1983
ID: 33715285
Thanks for links. Note we are running the 32bit version of windows server 2008 standard SP2
0
 

Author Comment

by:kevin1983
ID: 33715534
So perhaps its our anti-virus software thats causing a problem? we use AVG
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 33725448
i had this for a while on my physical backup server, which runs BE 12.0d and 2008 R2, after a reboot it backs up all my servers (mainly VM ones) by early following morning, but for the last few months, if it hasn't been restarted in a while, the jobs can sometimes drag onto the early afternoon.

made sure my server was fully patches from MS and Symantec, and have updated various HP drivers, including the NIC (teamed) and it seems to have settled down for now.  there are some tweaks you can do for 2008 servers which need to access 2000/2003 servers, and SMB v1 & v2 could also be part of the issue.
0
 

Author Comment

by:kevin1983
ID: 33928231
Still having problems, the symantec software is up to date, IainNIX: are you able to expand on clarifying the tweaks you did please?
0
 
LVL 20

Accepted Solution

by:
Iain MacMillan earned 500 total points
ID: 33936102
one of the main tweaks was to disable IPv6 on the 2008 NIC, also the SMB2.0 issue can be addressed by shutting it down, but you would normally do this to a client system such as Win 7 when accessing 200/2003 servers, but i will paste in the full command below - editing the registry is at your own risk.

So, for troubleshooting purposes, mostly in an environment that has mixes operating systems, you might want to consider disabling SMB 2.0. You need to do so on both the "client" and the "server" operating systems. To disable SMB 2.0 for Windows Vista or Windows 7 systems that are the “client” systems run the following commands:

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled

Note there's an extra " " (space) after the "=" sign.

To enable back SMB 2.0 for Windows Vista or Windows 7 systems that are the “client” systems run the following commands:

sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc config mrxsmb20 start= auto

Again, note there's an extra " " (space) after the "=" sign.
In order to disable SMB 2.0 on the server-side computer, follow these steps:1. Run "regedit" on Windows Server 2008 based computer.   2. Expand and locate the sub tree as follows.      HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters   3. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)      Value name: Smb2      Value type: REG_DWORD      0 = disabled      1 = enabled   4. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.   5. Reboot the server.
0
 

Author Comment

by:kevin1983
ID: 33955792
IainNIX: Thanks for this information. I will try what you suggested and let you know the results
0
 

Author Comment

by:kevin1983
ID: 34085130
IainNIX: I made the registry change you suggested on the 2008 server to disable SMB2 and also disabled IP6 on the server. The backup seems to run at normal speed the last few evenings but ill leave it a day or two more to see if it continues the same and will update you.

Thanks
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34085654
thanks for the update.
0
 

Author Closing Comment

by:kevin1983
ID: 34134960
Thanks for your solution. Backups seem to be running normal now at about the time we would exoect to see.
(P.s sorry about the delay confirming)

0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34135199
great, glad you got it fixed.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

VM backup deduplication is a method of reducing the amount of storage space needed to save VM backups. In most organizations, VMs contain many duplicate copies of data, such as VMs deployed from the same template, VMs with the same OS, or VMs that h…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question