[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Outlook 2007 Cert/RPC over HTTP issue

Posted on 2010-09-20
13
Medium Priority
?
676 Views
Last Modified: 2012-05-10
The sales team at a client’s company are using RPC over HTTP in outlook 2007 to connect to their emails from home. In outlook 2003 this always has and still does work fine. However they are now getting a certificate error (attached)
The interesting this is this is only happening in this version of outlook for machines that are attached to the corporate domain. If the machine is in a workgroup there is no issue.
The MSSTD proxy is set to the CN of the certificate but still we are getting errors. Short of turning the proxy feature off within exchange I am out of ideas. Any help would be much appreciated.
 Certificate Error
0
Comment
Question by:lil_dan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
13 Comments
 
LVL 26

Expert Comment

by:e_aravind
ID: 33716747
0
 

Author Comment

by:lil_dan
ID: 33716820
mail.pensionsfirst.com is working from the internet and internally, im not sure you are meant to hit a page when browsing to rpcproxy.dll are you?
0
 

Author Comment

by:lil_dan
ID: 33716865
Actually when browsing the dll it prompts for a username and password and authenticates successfully using corporate username and pw combination - both internet and internal.  
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 32

Expert Comment

by:endital1097
ID: 33717267
0
 
LVL 26

Expert Comment

by:e_aravind
ID: 33718550
Just curious, if you run
Set-OutlookProvider -Identity EXPR none

Note: its not $null but none and try to repair the OL2k7 profiles ...then test against the exchange server
0
 

Author Comment

by:lil_dan
ID: 33723512
The results from the article are as follows

Get-ExchangeCertificate | where { $_.Services.ToString(
).Contains("IIS") -eq $true } | fl Cert*


CertificateDomains : {ftp.pensionsfirst.com, mail.pensionsfirst.com}
CertificateRequest :

Get-ClientAccessServer uklonsvrex1 | fl AutoDiscoverSer
viceInternalUri


AutoDiscoverServiceInternalUri : https://mail.pensionsfirst.com/autodiscover/au
                                 todiscover.xml


Get-WebServicesVirtualDirectory | fl *Url


InternalNLBBypassUrl : https://uklonsvrex1.corp.pf.com/ews/exchange.asmx
InternalUrl          : https://mail.pensionsfirst.com/ews/exchange.asmx
ExternalUrl          :

Get-OabVirtualDirectory | fl *Url


InternalUrl : http://uklonsvrex1.corp.pf.com/OAB
ExternalUrl :


Get-AutodiscoverVirtualDirectory | fl *Url


InternalUrl :
ExternalUrl :


Get-OutlookAnywhere | fl External*


ExternalHostname : mail.pensionsfirst.com

Unfortunatley the Set-OutlookProvider -Identity EXPR none
 returns:

Set-OutlookProvider : A parameter cannot be found that matches parameter name '
none'.
At line:1 char:20
+ Set-OutlookProvider  <<<< -Identity EXPR none

and Set-OutlookProvider -Identity EXPR returns

WARNING: The command completed successfully but no settings of 'EXPR' have been
 modified.

either way its not working still. Thanks for your help so far - any further assistance would be really appreciated! :)

0
 
LVL 32

Expert Comment

by:endital1097
ID: 33724047
you need to update your oab vdir

set-oabvirtualdirectory oab* -InternalUrl https://mail.pensionsfirst.com/oab
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 1500 total points
ID: 33724061
also post the results from
get-outlookprovider expr | fl

server and certprincipalname should both be blank
if either are not run

set-outlookprovider expr -server $null -certprincipalname $null
0
 

Author Comment

by:lil_dan
ID: 33724586
@endital1097 - Should the cert pincipal name not be that of the cert with a prefix of msstd: ?
This means i can tick the "only connect to proxy servers with this principal name" box in outlook, ensuring the security of the connection does it not?
msstd.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33735252
no, this certprincipalname value should be blank except for a few circumstances
your configuration does not require a value
0
 

Author Closing Comment

by:lil_dan
ID: 33754306
The solution is a work around that fixes the problem - the issue is it allows people to connect without selecting SSL proxy settings within outlook, which in turn creates a security risk. However if you are looking for quick fix this definitely works.
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question