Improve company productivity with a Business Account.Sign Up

x
?
Solved

RDP to Windows XP in company-network not possible

Posted on 2010-09-20
7
Medium Priority
?
354 Views
Last Modified: 2012-08-13
Hallo,
I have a problem with the setup of Remote Desktop for a Client PC on our company-network. It's like this: Windows Server 2003 gives fixed IP to XP Client (SP 3). The firewall forwards the port (mine 3386) to the Client-IP. On the Client, I have enabled RDP, added some users and changed the RDP port to 3386 in registry.

The error is not very helpful: "This computer can't connect to the remote copmuter. Try connecting again. If the problem continues ..."

Any idea what could be the problem? Do I need to enable/install something on the Server? Thanks in advance for your help.
0
Comment
Question by:skiaholic
  • 4
  • 2
7 Comments
 
LVL 7

Expert Comment

by:John Jennings
ID: 33717867
Are you trying to connect FROM XP to Server 2003?

If so, have you enabled Remote Desktop on Server 2003?
0
 
LVL 20

Expert Comment

by:wolfcamel
ID: 33717901
first confirm you can rdp to it, on that port, from another PC locally - this will eliminate any router issues. and confirm your reg changes worked
0
 

Author Comment

by:skiaholic
ID: 33717904
I'm trying to connect from another XP client to the XP client with RDP enabled.
On Server 2003 RDP is enabled also and works.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
LVL 7

Accepted Solution

by:
John Jennings earned 2000 total points
ID: 33717940
On the client machine that you want to connect to, is Windows Firewall enabled?
If so, did you make an exception for port 3386?

Also, is this an internal-to-internal RDP connection? Are you going over the LAN or from the WAN?
0
 
LVL 7

Expert Comment

by:John Jennings
ID: 33717959
Also, as just a note in case you didn't know, once you modify the port in the registry, you have to explicitly define it in Remote Desktop Connection.

For example, when typing in the address you want to connect to, it would look like:
192.168.3.100:3386
0
 

Author Closing Comment

by:skiaholic
ID: 33717980
That was fast, thanks a lot!
The XP client had the firewall on also, I added the exception for the port and now it's working.
0
 
LVL 7

Expert Comment

by:John Jennings
ID: 33718024
Awesome skiaholic! Glad it worked for you. :)
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
Nuance's PaperPort may display this error message: PaperPort appears to be running Windows XP Compatibility Mode which may result in errors. We recommend disabling Compatibility Mode for the PaprPort.exe program, see Technote 6629. This articl…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question