email won't send with a signature

Hi again experts!

I have never seen nor heard anything like this problem.  Several users with different email address from multiple locations are reporting that their email is not being received.  I have talked to my ISP and there are no blacklist issues with our ip address.  Through a never ending troubleshooting process I have discovered that email does get received if there is no signature associated with the email.

The email does clear the outbox and ends up in sent items.  No idea what to do from here.  Any suggestions?

Thanks in advance

Who is Participating?
insanegainConnect With a Mentor Author Commented:
Looks like we solved the problem.  Talked to the email host and they said there was something in the signature that was getting blocked by their filters.  Closer testing indicated that it was the email address itself that referenced the domain name.  News to me.

Thanks for you help though.

Is there a picture or other non text item in the signatures?
insanegainAuthor Commented:
Checked that too.  I removed any images and still had the same problem.  I never had any images on mine, just text formatting with a hyperlink.

I changed my signature to plain txt and still no luck.

Also tried changing outgoing email servers with the same results.

Checking it against my hotmail address so no problems receiving on that account.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.