Set login screen username

I'm looking for a way to set the username field on the login screen to always default to the same login name. So for instance, if the login name I want displayed by default in the username filed is tuser,  and user logs in with username jsmith, when they logoff or the computer is restarted the username field will automatically go back to tuser.

Thank you
heydudeAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
JarrodConnect With a Mentor Commented:
I cant say ive done it but the first that springs to mind is running a command on logout to set the registry key at HKLM\Software\Microsoft\Windows NT\Current Version\Winlogon and adjust the defaultusername field. Dont see if being to big a security issue if its just a basic username for a kiosk style environment. Hope this helps
0
 
DrDamnitCommented:
As far as I know, no.

This would be a huge security issue if we could programatically set the login screen usernames.

But let's see if someone else has a better (working) idea.
0
 
Sushil DiasMgr.Commented:
Does this answer your query?
1. Click Start, click Run, type mmc, and then click OK.
2. On the Console menu, click Add/Remove Snap-in.
3. Click Add.
4. Click the Group Policy snap-in, and then click Add.
5. Click the target Group Policy object (GPO). The default setting is the local computer. Click Browse to select other GPOs that are available on the network. Click Finish.
6. Click Close, and then click OK.
7. Expand the Computer Configuration node, the Windows Settings node, and the Security Settings node.
8. Expand the Local Policies node, and then click Security Options.
9. In the right pane, double-click the Do not display last user name in logon screen entry.
10. Click Enabled.
11. Click OK.
12. Close the Group Policy console and restart the computer.

 
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
atuldelhiCommented:
Check User Accounts option first in Control panel to make sure the way you logon. Then you can follow below steps

Click Start, click Run, type mmc, and then click OK. . On the Console menu, click Add/Remove Snap-in.
. Click Add.  Click the Group Policy snap-in, and then click Add.  Click the target Group Policy object (GPO). The default setting is the local computer. Click Browse to select other GPOs that are available on the network. Click Finish. Click Close, and then click OK.  Expand the Computer Configuration node, the Windows Settings node, and the Security Settings node. Expand the Local Policies node, and then click Security Options.  In the right pane, double-click the Do not display last user name in logon screen entry.
Click Enabled. Click OK.

Reboot the computer and check. I hope this will resolve your problem.
0
 
heydudeAuthor Commented:
I was a little confused about setting the Do not display last user name in logon screen option. I thought that just blanks out the username field. I set the option to see what would happen, and it just blanked out the username field. I'm looking to have the system default back to a certain login after the computer is logged off or shutdown. If user jsmith logs into the computer for example, I want the default user tuser if that was the name for example to pop back into the username field. So no mater who logs into the computers in the lab, it will always default back the username tuser
0
 
heydudeAuthor Commented:
I tried making this registry change for the user I want to display, and it worked. I didn't have to create a script.


Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.