Solved

How to allow remote connection in SQL Server?

Posted on 2010-09-21
5
613 Views
Last Modified: 2012-08-13
Hi Guys,

How to allow remote connection in SQL Server?

My error message is here :

TITLE: Connect to Database Engine
------------------------------

Cannot connect to aslon-lt.

------------------------------
ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the pre-login handshake.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------
0
Comment
Question by:softbless
5 Comments
 
LVL 142

Assisted Solution

by:Guy Hengel [angelIII / a3]
Guy Hengel [angelIII / a3] earned 50 total points
ID: 33723352
you should read this support note to configure this:
http://support.microsoft.com/kb/914277

apart from that, check this article to troubleshoot the most common connection issues:
http://www.experts-exchange.com/A_1881.html
0
 
LVL 4

Assisted Solution

by:goyal_251
goyal_251 earned 50 total points
ID: 33723354
0
 
LVL 15

Accepted Solution

by:
AmmarR earned 250 total points
ID: 33723376
Dear softbless

there could be several reasons

1. are you using default port 1433 or a different port, if you are using a different port you should connect to the following

server,portnumber

check links below for more troubleshooting details

http://support.microsoft.com/kb/914277

http://blogs.msdn.com/b/sql_protocols/archive/2005/12/22/506607.aspx

Regards
0
 
LVL 4

Assisted Solution

by:samijsr
samijsr earned 150 total points
ID: 33732204
Check your Server Setting, weather Allow remote connection to this Server is checked or not.

Right Click on Server  -> Properties  -> Connections

If it is Un-checked, then checked this.

If still not able to connect remotely, then check the Port as default port 1433 there should be no problem, otherwise you have to specify the Port as well
Note: check your Port
0
 

Author Closing Comment

by:softbless
ID: 33846802
Thanks
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi all, It is important and often overlooked to understand “Database properties”. Often we see questions about "log files" or "where is the database" and one of the easiest ways to get general information about your database is to use “Database p…
In this article I will describe the Backup & Restore method as one possible migration process and I will add the extra tasks needed for an upgrade when and where is applied so it will cover all.
This is a video that shows how the OnPage alerts system integrates into ConnectWise, how a trigger is set, how a page is sent via the trigger, and how the SENT, DELIVERED, READ & REPLIED receipts get entered into the internal tab of the ConnectWise …
Need to grow your business through quality cloud solutions? With everything required to build a cloud platform and solution, you may feel like the distance between you and the cloud is quite long. Help is here. Spend some time learning about the Con…

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now