Cisco router interface not FDX

HI,

I have a cisco 1841 router and one fastethernet interface connected to a switch onlu half duplex... not full.

Why?

See the attached code.

regards
interface FastEthernet0/1
 description $ETH-WAN$$FW_OUTSIDE$
 ip address xxxxxxxxxxxxxxxx
 ip access-group 103 in
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip nat outside
 ip virtual-reassembly max-reassemblies 75
 speed 100
 full-duplex
 snmp trap ip verify drop-rate
 no mop enabled
 crypto map cmap-dele

Open in new window

heze54Asked:
Who is Participating?
 
dazm_2000Connect With a Mentor Commented:
You need to make the switch and the router interface the same ie

Both 100/full or
both auto / auto

The issue you have right now is because you have a mismatch of fixed and auto configuration.

Change the 1841 to auto speed and auto duplex or if its easier change the switch to 100 full and duplex full.

On the 1841 become enabled

ena
<password>

conf t
int FastEthernet0/1
speed auto
duplex auto
end
wri mem

Just bear in mind that if you aren't plugged into the console port you might cut yourself off if the line protocol on the FastEthernet0/1 drops as you are making your changes if you are connecting to the router via connectivity that uses FastEthernet0/1

Cheers daz
0
 
dazm_2000Commented:
Can you confirm your switchport is set for  - speed 100 and duplex full?.

If you cannot manage the switch then set your 1841 interface to

speed auto
duplex full

Please note the cable from the 1841 to the switch should also be a straight through cat5

Cheers darren
0
 
heze54Author Commented:
Hi,

The switch is auto port 10/100 fdx

0
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

 
heze54Author Commented:
I´ll do those changes.....
0
 
heze54Author Commented:
changes done

reboot is  requiered?
0
 
heze54Author Commented:
Lovely...It works


Thanks a lot
0
 
dazm_2000Commented:
Cool glad to be of assistance
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.