Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 935
  • Last Modified:

Do not have permission to set my own Out Of Office

I'm having an issue with my PC where I cannot set my Out Of Office Assistant. When I try to open it I get an error saying:

'Your autoreply message cannot be displayed. You fo not have sufficient permission to perform this operation on this object. See the folder contact or your system administrator.'

I'm using Outlook 2007 with Exchange 2003. I've tried removing Cached Exchange Mode and I've also deleted my Outlook profile in Control Panel and re-created it. Neither of those solutions worked.

Any help would be very much appreciated.
0
ISGJackson08
Asked:
ISGJackson08
  • 4
  • 2
  • 2
  • +1
1 Solution
 
smartsidCommented:
Can you please confirm that your outlook is connected to Exchange. If it is, try removing cached exchange mode of Outlook.
0
 
ISGJackson08Author Commented:
It's definitely online with Exchange. As per my original post, I've already tried removing Cached Exchange Mode. Unfortunately it didn't help.
0
 
rakeshmiglaniCommented:
are other users also facing the same issue or is it only you?
are you able to do it via OWA?
are you able to do it if you re-create your outlook profile?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
smartsidCommented:
Are you able to set OOF thorugh Outlook Web Access ? Through this we can find that either the issue is with Outlook or with your Mailbox.
0
 
ISGJackson08Author Commented:
Re-creating the Outlook profile didn't work either. I tried that along with removed Cached Exchange Mode.

OWA - Tried that, though forgot to put it in my original post. I get the same error.

Also tried setting it whilst logged in using the Domain Admin account on one of our DCs. Same error again. I checked permissions in AD for Exchange and I do have full mailbox access.

Far as I'm aware, I'm the only user on our Domain with this problem.
0
 
rakeshmiglaniCommented:
did this use to work earlier?
there seems to be some corruption in the OOF rules of your mailbox.

you can check http://www.windowsitpro.com/article/administration-tools2/using-mfcmapi-to-delete-an-out-of-office-rule.aspx and http://exchangeshare.blogspot.com/2007/05/delete-corrupted-out-of-office-rule.html for the steps to delete the rules and then try to create new ones.

just make sure that mfcmapi is a very powerfull tool that you should use it very carefully
0
 
e_aravindCommented:
Do you want try using  "Outlook /CleanRules", "Outlook /CleanClientRules", "Outlook /CleanServerRules" and see any luck
0
 
ISGJackson08Author Commented:
The cleanrules command has fixed it.

For Info: I downloaded the tool suggested by rakeshmiglani and followed the instructions. Deletion of the entry advised didn't appear to have resolved the issue. The instructions say that, once deleted, Outlook should re-create the entry, but it didn't. I still got the same error as before. I also find that my Outlook doesn't close properly anymore. The service just seems to crash and then I get the usual 'End Task' window in Windows.

0
 
ISGJackson08Author Commented:
The problem was resolved with the selected suggestion.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now