• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 716
  • Last Modified:

Create file with File Preferences GP

For some reason the following file preferences GP is not working...

Action: Create
Source file(s): \\SERVER\Data\Logon Script Files\Desktop Shortcuts\File.ext
Destination file: \\SERVER\Users\User Files\%USERNAME%\Desktop\File.ext
Read-only: Disabled
Hidden: Disabled
Archive: Disabled

The user has read/execute permission on the source and full permission on destination.

I can confirm the the Group Policy this setting is in, is working for the user and machine.

Regards
0
cbsbutler
Asked:
cbsbutler
3 Solutions
 
Joseph MoodyBlogger and wearer of all hats.Commented:
Are you using loopback policy processing?
0
 
cbsbutlerAuthor Commented:
Loopback policy is not configured.
The user account and computer account are both covered by the GP.
0
 
Justin OwensITIL Problem ManagerCommented:
When you run RSOP on that machine, you see the policy as in-place and running, correct? When you say the user and computer accounts are both covered, do you mean you set up this policy in both user settings and in computer settings?

Justin
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
jjmartineziiiCommented:
what error do you have in your event viewer? any error at all?
0
 
cbsbutlerAuthor Commented:
The GPO is applied to an OU that contains both the computer and user account.
The settings in question are set under User Configuration.

RSOP does not show any GP Preferences. However settings present in the GPO do appear in RSOP.
0
 
cbsbutlerAuthor Commented:
@ jjmartineziii

The user 'file.ext' preference item in the 'Windows {0FABA142-9FBF-4139-808B-E03E736F9343}' Group Policy object did not apply because it failed with error code '0x80070005 Access is denied.' This error was suppressed.
0
 
Justin OwensITIL Problem ManagerCommented:
Does SYSTEM have access to those folders as well as the specified user?
0
 
cbsbutlerAuthor Commented:
SYSTEM has full access to both folders and contents.

The folders are located on a share. Does SYSTEM need permission to the share aswel? As all that is currently is set is "authenticated users"
0
 
Justin OwensITIL Problem ManagerCommented:
This is something that needs to be addressed on almost every file server.  Pick one: share level permissions or NTFS level permissions.  You can have difficulties when you do both.  I ALWAYS use NTFS level permissions.  As a result, the SHARE level permissions are ALWAYS EVERYONE FULL.  When NTFS permissions are set up correctly, you don't have any worries, and it will remove a lot of headaches.

Do you mind trying that?
0
 
cbsbutlerAuthor Commented:
The Share level is set to Everyone Full.
Still same problem.
0
 
Justin OwensITIL Problem ManagerCommented:
Can you

1) Get to that share from the command line?
2) Get to the top level of that share and drill down to it?
0
 
cbsbutlerAuthor Commented:
1. yes
2. yes
0
 
Justin OwensITIL Problem ManagerCommented:
I am trying not to assume anything, so I will ask.  Did you delete (or disable) the GPO which does this and create a new one to see if it also errors out?
0
 
cbsbutlerAuthor Commented:
Hi DrUltima, tried as you suggested and unfortunately the same error occurred.
0
 
Justin OwensITIL Problem ManagerCommented:
OK, I suppose the next logical step is to determine if you can use this methodology to create ANY files.  Can you try to create a different file completely?
0
 
cbsbutlerAuthor Commented:


Hi DrUltima,
I have tried creating a different file, same error.

In the same GPO I have the following file create preference running (and working)
Action: Create
Source: \\SERVER\Data\Logon Script Files\Desktop Shortcuts\WordTemplate.dot
Destination: %PROGRAMFILES%\Microsoft Office\OFFICE11\STARTUP\WordTemplate.dot

I'm certain the issue is writing to the destination, but the local user and SYSTEM have full write access to the desintation. As well as "everyone" being set full permission on the share.


0
 
Justin OwensITIL Problem ManagerCommented:
Can you create your policy, but instead of writing to %USERNAME%, use a static path? You would have to create a separate share with the appropriate permissions.  I am trying to determine exactly where the GPO is breaking.  If you can create that file in a static location but cannot create any file with that variable location, we need to track more closely to that path....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now