Solved

how do you remove the prefix of https for owa

Posted on 2010-09-21
7
825 Views
Last Modified: 2012-05-10
When users log into their owa or vpn through the web they have to type https://mail.domain.com/owa or for the vpn https://vpn.domain.com. We want to have it set so that either way will work. With the https or without the https. ie mail.domain.com/owa typed into a browser we'd like to have working as well as it with the https.
Exchange 2007 standard
IIS 7
Platform is Server 2008 standard 64bit

Thanks,
BW
0
Comment
Question by:bwinkworth
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 8

Expert Comment

by:dmeeren
ID: 33724810
I think creating a redirect would be a solution. Create a index file with: <meta http-equiv="refresh" content="3; URL=https:///....."> in the header.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 33724824
0
 
LVL 10

Expert Comment

by:abhijitwaikar
ID: 33724995
Check below link if help you as same above but with GUI:
http://www.trainsignaltraining.com/windows-server-2008-http-redirection/2008-03-27/
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 30

Expert Comment

by:Brad Howe
ID: 33725092

Hi bwinkworth,
I love pushing URL Rewrite. You can use the URL rewrite feature. You can get the URL rewrite module from iis.net.

Download the x86/x64 version for IIS 7.0
http://www.iis.net/download/URLRewrite 

Here is a great article on how to create 301 redirect rules.
http://learn.iis.net/page.aspx/461/creating-rewrite-rules-for-the-url-rewrite-module/ 

Example Rule for mail.domain.com or vpn.domain.com redirect to mail.domain.com/owa

1. Install the IIS7 URL rewrite Module.
2. Go to IIS Manager
3. Select your “Web Site” on the left pane.
4. In the IIS Feature View, click on "URL Rewrite".
5.In the "Actions" pane on right hand side, click on "Add Rules..."
6. Create a Blank Rule, click OK.
7. Follow the details below.

NAME - Force HTTPS and redirect to /owa
MATCH URL
   Requested URL: Matches the pattern                              Using:  Regular Expressions
   Pattern : (.*)                                                                     Ignore Case :  "Checked"
CONDITIONS
  Logical Grouping: MatchAny                          
          {HTTPS}      - Match the pattern - off
          {HTTP_HOST}  - Match the pattern - ^(vpn|mail)\.domain\.com$
 
ACTION
  Action Type:  Redirect
  Redirect URL:  https://www.mail.domain.com/owa
 Append query string:  "unchecked"
  Redirect Type:  Permanent (301)

Now your web site will respond as usual and only redirect the virtual root /abc to www.google.com 

Let us know,
Cheers, Hades666
0
 

Author Comment

by:bwinkworth
ID: 33778762
akhater,
 I followed the procedure in your article you provided and went to the 'http redirect' of the default website and entered 'https://mail.mydomain.com/owa' and checked 'Only redirect requests to content in this directory (not subdirectories)' and set the status code to 'Found(302)' and then did an iisreset on the Exchange server. I noticed at the bottom of the procedure it states this:

"When you configure redirection from a top-level directory in Windows Server 2008, the settings are propagated to lower-level directories. For example, when you configure redirection to the /owa virtual directory as shown in the previous procedures, the settings that you configured on the Default Web Site also appear on the HTTP Redirect page of all the virtual directories, such as /Autodiscover, /Exchange, and /Public. Therefore, you must remove redirection from all the virtual directories except the one that you want redirected."

Do I need to do this to all my subdirectories except the owa one? Will this mess things up for anything else? Can't I just do the procedure on the 'owa' subdirectory instead of on 'Default Website' Here's a screen shot of my subs...

Thanks,
bw
subdirs.JPG
0
 

Author Comment

by:bwinkworth
ID: 33822306
Or did that not make sense?

Thanks,
bw
0
 

Accepted Solution

by:
bwinkworth earned 0 total points
ID: 33937405
I was able to work this out by editing the 403-Forbidden error and redirecting it to https://myserver/owa

BW
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
This video discusses moving either the default database or any database to a new volume.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question