• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1845
  • Last Modified:

Can't activate rails (= 2.3.5, runtime) for [], already activated rails-3.0.0 for [] (Gem::LoadError)

I have an application which was built on a 2.3.5 rails platform.

Runs through normally with 2.3.8 as well.

I have a new Windows server which I've installed ruby 1.9.2p0 and then did a gem install rails.

It installed the rails v3.0. I then went to install rails -v=2.3.5 so that I can run the application.

However, when I ran rake db:migrate, it gave the error saying that 3.0 is already activated therefore it can't run.

I'd like to ensure that my application runs.

Can someone help me on what I need to do. I can't run ruby script/server nor any rake commands...

I need this to run on Windows due to some constraints that I have.

Thanks
0
binele
Asked:
binele
1 Solution
 
JESiiCommented:
I'd try  a
   gem uninstall rails
and/or explicitly uninstalling all the piece-parts:
   gem uninstall activerecord
   gem uninstall active support
   ...
and then a gem install rails --version '=2.3.5'
0
 
narshlobCommented:
It looks like you might have a gem or another part of your application requiring rails v3.0.
If I were you, I'd look into using RVM. You can split up your ruby versions and use gemsets to test out different versions of gems / ruby.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now