Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Trouble crawling Exchange Public Folder in SharePoint 2010

Posted on 2010-09-21
3
Medium Priority
?
1,366 Views
Last Modified: 2012-05-10
I've recently moved some email archives to an exchange public folder and I'm trying to add a new Content Source in the SharePoint Search Engine Application. I keep running into errors when attempting to crawl the location. The latest error I'm getting is Access forbidden 403 errors. It generates a warning with Event ID 14 in the event log. I've added read access permissions for the default content access account and I'm still getting that error. I've followed the microsoft KB article on crawling Exchange 2010 public folders by logging into webmail and browsing to the folder I'm trying to crawl and then opening it in a new window and copying and pasting that URL but I'm still getting the errors. Any ideas?
0
Comment
Question by:Wilmette
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 1

Accepted Solution

by:
jtoddwalker earned 2000 total points
ID: 33727646
Try disabling the loopback check per http://support.microsoft.com/kb/971382

This is frequently the cause of crawling issues. BTW, Method 1 of specifying host names used to work, but I beilieve with new versions of Windows Server like 2008 you have to use Method 2 to completely disable the loopback check.
0
 

Author Comment

by:Wilmette
ID: 33727973
Thanks for the feedback. I did have to disable loopback check earlier in the project in order to crawl content using a friendlier URL like portal.domain.com instead of the default server URL. Also this error is not giving me that "you may not have access with the default content access account" type error message like Sharepoint did before I disabled loopback check. So I must have something else buggered up.
0
 
LVL 1

Expert Comment

by:jtoddwalker
ID: 33729989
If you are using the web URL to try and crawl the exchange public folders and that web site is configured to use forms based authentication, then that is likely the problem. In that case you would probably need to configure an alternate URL in Exchange/IIS that is accessible via Windows Integrated authentication. I know that at least in SharePoint 2007 it did not support crawling web sites that required forms based authentication.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question