Solved

Printer failing

Posted on 2010-09-21
7
1,049 Views
Last Modified: 2012-05-10
I have a dedicated pc setup with XP SP2 as a print server and an IKON CPP500 attached and shared. Today I had a user report that when attempting to print from Word/Excel 2003 the application crashes and then restarts but the job is lost. The event logs from both machines show no print errors. I have roughly 25 other devices printing to the print server with either XP SP3 or MAC OS 10.5. He is the only user so far reporting any issues. I have removed the shared printer, rebooted and installed again but the problem persists. When attempting to open the property page of the printer the following error is listed

"Function address 0x7c90fe60 caused a protection fault. (Exception code 0x00000005). Some or property pages may not be displayed"

Most of the research I have seen indicates this is typical with direct or IP based printers and most of the printers are HP. any input would be greatly appreciated.
0
Comment
Question by:CNEAdmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 2

Expert Comment

by:HFVgally
ID: 33725966
When you reinstalled the printer did it prompt you whether or not you wanted to replace the driver and if so did you?
Is the user attempting to print one of the Windows XP SP3 systems? Is this a relatively new problem (tried system restore)? Since the properties option isn't working properly, I take it that means that you can't try a test page. Does a Notepad job crash?.
If no other systems have a problem accessing the property pages, then the issue must be on the local machine, but it sounds like some kind of corruption in the print spooler. You could try the standard fix of Stop Print Spooler service, navigate to Windows\system32\spool\PRINTERS and delete any files you still see there (remnants of print jobs gone bad - if the spooler is stopped there shoud be nothing there) and then restart the print spooler service.
If that doesn't work, system restore or try either or both of these:
http://support.microsoft.com/kb/2000007 (additional info at http://blogs.technet.com/b/fixit4me/archive/2009/05/27/fix-print-spooler.aspx)
http://support.microsoft.com/gp/printing_problems?entrypoint=WHHT
0
 

Author Comment

by:CNEAdmin
ID: 33726073
Since it is pulling the driver from the shared printer it does not request any installation of a driver. I have tried stopping the spooler and clearing the contents of the spool directory but there has not been anything listed. The user has 6 other IP printers, this is the only one shared and I was hoping to avoid deleting all printers and contents of the spool folder but it looks like that may be my next step.

This is the only pc experiencing the issue and I have not tried from notepad only Word/Excel and test page (which obviously doesnt work since I cannot open the properties page.)

I did look at system restore but their are only system check points and nothing is changed when reverting to a day or 2 days ago. The issue just started today.

Thanks for the suggestions. It will be tomorrow before I can work on this issue again so I will post the results.
0
 
LVL 2

Expert Comment

by:HFVgally
ID: 33726471
You could look at this: http://support.microsoft.com/kb/924078. I believe that the hotfix won't apply given that you are on SP3, but the process of removing the driver from the local computer's print server may help (assuming it's not a standard bundled driver already, I suppose).
Does the local user have full admin rights to the local machine? Any user permission changes recently? If you log on as a different user, say the local adminstrator, does it make a difference?
0
Is Your DevOps Pipeline Leaking?

Is your CI/CD pipeline a hodge-podge of randomly connected tools? You’ve likely got a tool to fix one problem & then a different tool to fix another, resulting in a cluster of tools with overlapping functionality. Learn how to optimize your pipeline with Gartner's recommendations

 

Author Comment

by:CNEAdmin
ID: 33734257
I have logged in as administrator and the user has local admin rights with the same issue. The user is too busy for me to address today so I am currently on hold with them. Thanks again for the input. As soon as I get back to the issue I will publish findings and hopefully the resolution.
0
 
LVL 10

Expert Comment

by:David_Ingledew
ID: 33777138
Remember XP has a limit of 10 concurrent connections, after that strange things happen....
0
 

Accepted Solution

by:
CNEAdmin earned 0 total points
ID: 33889394
The printer is being replaced and as this was an isolated incident I will not pursue an answer. If the issue persists after the new printer I will re-open. Thanks again to all who provided feedback.
0
 
LVL 2

Expert Comment

by:HFVgally
ID: 33890254
I suspect that the issue will not persist with a new printer. I would personally like to know if removing and reinstalling the driver per the KB article had any impact or for that matter if the proposed Microsoft Fix It resources (from my first response) resolved the issue. I don't expect that the 10 connection default workstation limitation applies in this case as suggested by David because a) this has worked before without problem and b) if you computer is joined to an AD domain or (I believe) even to an Netware network, those limitations go away as it becomes a shared network resource and connectivity is overseen by AD or DS - so the peer-to-peer default rules no longer apply.
I understand if you decide it's not worth your time to pursue the solution, but since you did ask for assistance through EE and a best attempt was made to provide it, I would appreciate award of at least partial credit for "best efforts." If you decied to follow up with the proposed untried solutions and invalidate them, I am fine with not recieving any credit whatsoever. At least then I gain the knowledge that none of those steps resolved the problem and that helps with my own internal "knowledge base."
Cheers, and good luck.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question