Exchange 2007 Managed Folder Policy not deleting messages from Inbox

Can anyone assist in troubleshooting a Managed Default Folder policy that's not working.  I've got a journaling mailbox that's filled up with 30 GB worth of mail that should be deleted every 60 days!
LVL 2
fredimacAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
endital1097Connect With a Mentor Commented:
you should have a managed content setting for the "Inbox - 60 days"
that managed default folder should be added to your managed folder mailbox policy

the managed content setting should look like the attached
2007-managedcontentsetting.PNG
0
 
geieeaCommented:
0
 
endital1097Commented:
make sure you have the managed content settings applied to a managed folder mailbox policy
make sure that policy is applied to the mailbox
go to properties of the mailbox server that contains the database hosting the mailbox
make sure you have a managed folder assistant schedule enabled

you can then run
Start-ManagedFolderAssistant
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
fredimacAuthor Commented:
fredimac:
09.21.2010 at 04:21PM PDT, ID: 33730341
Cutom managed default folder called: Inbox - 60 Days
Manged Folder Policy called Delete - 60 Days that covers Entire Mailbox
Managed Content settings that Permanently delete after 60 days
Policy is applied to the Journal Mailbox.

Question:  does the database have to be set to delete before backup in order for the deletions to happen directly?

When the Assistant runs, it leaves this message in the App log:

Service MSExchangeMailboxAssistants. Managed Folder Mailbox Assistant for database First Storage Group/Mailbox Database (975384cb-a44e-4331-9d6b-2eee43cb9de2) is exiting a scheduled time window. 80 out of 80 mailboxes were successfully processed. 0 mailboxes were skipped due to errors.  0 mailboxes were processed separately.  0 mailboxes were not processed due to insufficient time.


   

0
 
fredimacAuthor Commented:
Yep, tha'ts it exactly...
0
 
endital1097Commented:
where do you have this managed contetn setting added
0
 
endital1097Commented:
please post the results from
Get-ManagedContentSettings | fl
0
 
fredimacAuthor Commented:
MessageClassDisplayName    : All Mailbox Content
MessageClass               : *
Description                : Managed Content Settings
RetentionEnabled           : True
RetentionAction            : PermanentlyDelete
AgeLimitForRetention       : 60.00:00:00
MoveToDestinationFolder    :
TriggerForRetention        : WhenDelivered
MessageFormatForJournaling : UseTnef
JournalingEnabled          : False
AddressForJournaling       :
LabelForJournaling         :
ManagedFolder              : Inbox - 60 Days
ManagedFolderName          : Inbox - 60 Days
AdminDisplayName           :
ExchangeVersion            : 0.1 (8.0.535.0)
Name                       : Inbox - Delete 60 Days
DistinguishedName          : CN=Inbox - Delete 60 Days,CN=Inbox - 60 Days,CN=EL
                             C Folders Container,CN=INFOCOMGROUP,CN=Microsoft E
                             xchange,CN=Services,CN=Configuration,DC=domain,DC=local
Identity                   : Inbox - Delete 60 Days
Guid                       : 08661a74-e6dc-4804-ba6f-61a0142bb0c7
ObjectCategory             : domain.local/Configuration/Schema/ms-Exch-EL
                             C-Content-Settings
ObjectClass                : {top, msExchELCContentSettings}
WhenChanged                : 9/10/2010 12:29:26 PM
WhenCreated                : 9/9/2010 12:09:24 PM
OriginatingServer          : server.domain.local
IsValid                    : True

0
 
endital1097Commented:
please post (trying to see where the issue may be)
Get-ManagedFolder "Inbox - 60 Days"  | fl

get-mailboxserver ( get-mailbox journal).server | fl mana*
0
 
fredimacAuthor Commented:
I did just make a change... the policy was set to Entire mailbox not the inbox - 60 days.  Re-running the assistant now.

here's the results:
FolderType                : All
Description               : ManagedDefaultFolder
FolderName                : All
LocalizedFolderName       : {}
StorageQuota              : unlimited
Comment                   :
LocalizedComment          : {}
MustDisplayCommentEnabled : False
BaseFolderOnly            : False
TemplateIds               : {Delete items older than 60 days:  Inbox, Deleted &
                             Sent.}
AdminDisplayName          :
ExchangeVersion           : 0.1 (8.0.535.0)
Name                      : Inbox - 60 Days
DistinguishedName         : CN=Inbox - 60 Days,CN=ELC Folders Container,CN=domain,
                            CN=Microsoft Exchange,CN=Services,CN=Confi
                            guration,DC=domain,DC=local
Identity                  : Inbox - 60 Days
Guid                      : 269dcbf6-c4df-4347-9d16-aa85bc975d3c
ObjectCategory            : domain.local/Configuration/Schema/ms-Exch-ELC
                            -Folder
ObjectClass               : {top, msExchELCFolder}
WhenChanged               : 9/9/2010 12:03:57 PM
WhenCreated               : 9/9/2010 12:03:57 PM
OriginatingServer         : server.domain.local
IsValid                   : True

ManagedFolderAssistantSchedule : {Sun.1:00 PM-Sun.6:00 PM, Mon.1:00 PM-Mon.6:00
                                  PM, Tue.1:00 PM-Tue.6:00 PM, Wed.1:00 PM-Wed.
                                 6:00 PM, Thu.1:00 PM-Thu.6:00 PM, Fri.1:00 PM-
                                 Fri.6:00 PM, Sat.1:00 PM-Sat.6:00 PM}
0
 
endital1097Commented:
you can run this to monitor
get-mailboxstatistics journal | fl total*
0
 
fredimacAuthor Commented:
working
0
All Courses

From novice to tech pro — start learning today.