Solved

Outlook Web Access on the fritz again...

Posted on 2010-09-21
19
1,342 Views
Last Modified: 2012-05-10
I recently had a problem with OWA and Outlook RPC over HTTP.  The problem appeared to be the self-signed certificate so at the suggestion of alanhardisty I purchased an SSL certificate and installed.  All was working fine after that and I awarded the points happily and all was good.  Yesterday it was reported to me by one of our field guys that he could not access OWA.  I tried it in-house and it worked.  Last night I tried it from home and it did not work.  Now this morning from in-house, I cannot access.  I've been playing with it and setting a permission on the exchweb directory helped get me to the SSL login prompt but after logging in I get an "Unspecified error" in IE.  I will admit once again that I am no IIS expert and "get by with a little help from my friends" as once sung by Joe Cocker.  Any help would be much appreciated.  thanks - kevin
0
Comment
Question by:12vltmn
  • 7
  • 7
  • 3
  • +2
19 Comments
 
LVL 10

Expert Comment

by:jorlando66
ID: 33728515
Did you change something on the exchange server?  What exactly happens when you try to connect?  Can you ping the exchange server?

go here and run owa tests and post results please.

https://www.testexchangeconnectivity.com/
0
 

Author Comment

by:12vltmn
ID: 33728746
I did not change anything on the exchange server.  One thing I did discover is that I had not installed the intermediate certificate bundle, which I have now done with no change.  Sometimes when I try to connect using IE I simply get an unspecified error (I turned off the friendly error messages n IE - before that it errored with cannot display web page).  Sometimes I get the SSL login dialog box and I log in, then I get the unspecified error.  I'm not sure what to run on the testexchangeconnectivity.com site.  I have tried the Outlook Anywhere and it passed with a warning about the intermediate certificate (that is when I installed the intermediate bundle).  Yes, I can ping the exchange server and exchange is working properly AFAIK.  RPC over HTTP appears to be working also, at least when I test it from inside.
0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33728781
you say "sometimes" you get the login dialog box..Not always?  
0
 

Author Comment

by:12vltmn
ID: 33728891
That is correct.  A few times I have, most times I have not.  I believe I mentioned in my original post that I added "Authenticated users" to the security on the exchweb folder.  After I did that I got the login prompt, but since then I have not.  I just get "Unspecified error".
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 33729032
Have you done an IIS reset to restart the website on the Exchange server? Have you tried disabling SSL entirely and see if you can get to the OWA website with SSL turned off?
BTW, the song was written by John Lennon and Paul McCartney and originally performed (by Ringo IIRC)on the 1967 Beatles album Sgt. Pepper's Lonely Hearts Club Band.  Joe Cocker was a joe-come-lately on this one...And yes, I'm old enough to remember it well ;-)
0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33729058
OWA is the folder for web access.
what happens when you navigate to:

http://yourmailserver/owa
https://yourmailserver/owa
0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33729076
@ hypercat: Big Beatles fan here too..  :)  Thanks for the smile.

0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33729135
If the iisreset does not work you can try resetting the IIS exchange directories.

http://kb.notifylink.com/jivekb/servlet/KbServlet/download/1023-102-91/repair_exchange_as.pdf
0
 

Author Comment

by:12vltmn
ID: 33729176
hypercat:  yes, I have done several iisreset commands with no change.  I have not tried disabling SSL.  Where do I do that?

And I also am old enough to remember Sgt. Peppers and I knew that my all-time favorite rock-n-roll band originally wrote the song.  But Joe Cocker got more playing time with it and I wasn't sure how many geeks here were old enough to know that.  :)

jorlando66:  http gets me "the page must be viewed over a secure channel".  https gets me "there is a problem with this website's security certificate".  Hmmmm...  If I click to continue on to the page I get "the page cannot be found".
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 10

Expert Comment

by:jorlando66
ID: 33729243
personally I'd rebuild the IIS folders and see if that works.  It will leave you in a pre certificate state then you can apply the certs and see if they work again.
0
 
LVL 19

Expert Comment

by:R--R
ID: 33729264
Is there any event on the server related to OWA? please check.
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 33729325
You would disable SSL by editing the directory security in IIS Manager. Expand the website and click on the main website (Default Web Site usually), right-click, go to Properties/Directory Security.  Click on the item to Edit the Secure communicatons settings and remove any checkmarks. Particularly for OWA, the ExchWeb directory would be set to require SSL. It could possibly also be a NTFS permissions issue, but with the intermittent behavior you're seeing, I don't really think so.
LOL - that's why I was correcting you. I thought that some young and cocky (pun intended) techie was missing the true attribution for the tune and lyrics. (I gotta admit, I actually hated the Cocker version of the song....but then I was never a big fan of his.)
0
 

Author Comment

by:12vltmn
ID: 33729443
Nothing that I can find on OWA.  But I do have some of these.  Any idea how I deal with the number of named properties?  Sorry, totally unrelated:

Failed to create a new named property for database "First Storage Group\Mailbox Store ('mail server')" because the number of named properties reached the quota limit (8192).
 User attempting to create the named property: "joyce"
 Named property GUID: 00020386-0000-0000-c000-000000000046
 Named property name/id: "X-Ktfimk"

I will take a serious look at rebuilding the IIS folders.  I am probably best to be in a pre-certificate stage so I can install again correctly.  I'm not blowing away anything else, am I?
0
 

Author Comment

by:12vltmn
ID: 33729474
hypercat:  good to know we are on the same page musically.  :)  I didn't like Cocker's version as much either.  Although I did like a few of his songs (my absolute favorite is "you can leave your hat on").  And I also notice that we dress alike.  Should we know each other?  :)

I'll try the SSL first, then probably attempt the rebuilding of the IIS folders next.
0
 
LVL 38

Accepted Solution

by:
Hypercat (Deb) earned 250 total points
ID: 33729562
I think that's a good plan. I don't know where you got your cert, but you also might try approaching it from that end.  I had one situation where I downloaded a cert and it was somehow corrupted either during the download or after the fact. Re-downloading a new copy of the cert and then applying that to the website after uninstalling and reinstalling IIS fixed the problem for me. The uninstall/reinstall step may seem a bit drastic but it's also a fall-back position if resetting just the Exchange folders doesn't work.  Here's an article if you need to go that route:
http://support.microsoft.com/kb/320202
0
 

Author Comment

by:12vltmn
ID: 33729705
the cert came from godaddy.com and it worked fine for about a month.  ???  Yikes!  I hope I don't have to reinstall IIS.

I tried disabling the SSL requirement.  No change.  when accessing OWA both using http and https I get the logon dialog box, then the unspecified error.  I restored to the original settings.
0
 
LVL 10

Assisted Solution

by:jorlando66
jorlando66 earned 250 total points
ID: 33729988
you wont have to reinstall IIS.  Even if you did it isnt a big deal.  Try resetting the web folders back to default.  More often than not this works.  Give it a shot, reapply the certs and see where you are.
0
 

Author Comment

by:12vltmn
ID: 33771569
I still plan to attempt your suggestions regarding the recreation of the virtual folders.  I just haven't had time due to my other duties.  And since RPC over HTTP is working for our remote Outlook (Outlook Anywhere...called by several names) the OWA is not mission critical, although something that needs to be resolved.  thanks again!  I'll keep you posted when I make my attempt.
0
 
LVL 3

Expert Comment

by:prafullamjn
ID: 34428379
A few times I have, most times I have not.  I believe I mentioned in my original post that I added "Authenticated users" to the security on the exchweb folder.  After I did that I got the login prompt, but since then I have not.  I just get "Unspecified error".
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now