[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 951
  • Last Modified:

Server 2003 prompting for credentials when connection to Sharepoint docuemtn library via UNC

Hi all

I have a sharepoint document library http://mycompany/sites/documentLibrary. When browsing to this site through Internet Explorer on a terminal server I and other users can get to the site without being prompted for a username and password. The site appears as "local intranet"  according to IE.

When browsing to the UNC path \\mycompany\sites\documentLibrary we are being prompted for a username and password. After putting in the credentials the document library displays. I need for the server to be able to access the site via UNC path without being prompted for credentials as we have several in house applications relying on doing so

The funny thing is this was working until recently. What's changed? I have no idea. I have an almost identical terminal server on the same subnet/OS/windows patch level that allows access without prompting for a username or password, and then only thing I had to do for that server was enable the web client service..

Things I have tried so far:

- Checked the Web Client service is enabled, started and set to automatic. Restarted the server just to make sure.
- Added http://mycompany, \\mycompany etc to the trusted zone.
- Set the trusted zone security to low, and ensured the "automatic logon with current username and password" option is set
- Changed the order of Network Providers for the network adapters so that the Web Client Network provider is at the top
- Set basicauth to 1 (ssl only) as per http://support.microsoft.com/kb/841215
- Disabled strict name checking as per  http://support.microsoft.com/kb/281308/en-us
- Installed Web Folders update http://support.microsoft.com/kb/907306

After doing all that and restarting still no luck.

I am now out of ideas and this is affecting hundreds of users so please offer up any that you may have.

I'm also considering logging a case with Microsoft so if anyone has information on that specifically the number to call form Australia, the rates they charge for support and whether its worth it, I would be interesting in hearing about that
0
ashaw2009
Asked:
ashaw2009
1 Solution
 
ken2421Commented:
You have to ask yourself if it was working, what changed? Permissions are the most obious. It looks like you are following a solid path for troubleshooting. While I have not seen it this may be your case here

http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=c523ac7a-5724-48be-b973-641e805588f4

Ken
0
 
ashaw2009Author Commented:
Thanks for responding Ken. I have already read that article and it did help my undertstanding. I would highly recommend that article to anyone who is using UNC paths to connect to a sharpeoint document library

I managed to get this resolved by forcing UNC paths to be seen as intranet.
I created a value under
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap

DWORD:        UNCAsIntranet = 1

For some reasons my UNC paths were not being seen as intranet, even though I had added them to the local intranet settings in IE. This registry setting has forced it to be seen as local intranet and now I can connect without a username/password prompt.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now