?
Solved

SBS2003 DNS not working

Posted on 2010-09-21
11
Medium Priority
?
764 Views
Last Modified: 2012-05-10
I’ve got a situation where by SBS2003 server can’t seem to do a DNS lookup.  I know what caused the problem, but I’m not sure how to fix it.  Here's the details:

Completely functions system:  SBS Server and all client computers worked fine.  All systems, including the SBS have the SBS's IP (192.168.1.200) hard coded as the DNS server.  We were using a DSL line to connect to the internet, attached via cable modem to router.  Router provides DHCP functions.

Today, changed from DSL to high-speed cable.  Faster, cheaper...  Anyway, now DNS is not working.  If I configure a client system to get DNS automatically, bingo...  the client works great.  So I know the pipeline to the internet is functioning correctly.  So, the SBS is now not able to see the new DNS servers...

Question:  How/Where do I tell the SBS the IP's of the new DNS servers?  I don't recall setting this 4 years ago when we got the DSL line but I must have done something...  I tried hard-coding the DNS IP's on the SBS network card IP, but that didn’t help.

I ran internet connections wizard but it didnt help.
0
Comment
Question by:rick60
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 7

Expert Comment

by:supports
ID: 33730690
have you tried running connect to the internet wizard again on SBS....... if not.. try running it once
0
 

Author Comment

by:rick60
ID: 33730868
Yes...  3 or 4 times.  No change.  I did find the 'forwarders' in the DNS console, and found listed in there the old DNS server IP's.  I added the new ones, moved to top of list, but still not working.  
0
 
LVL 5

Expert Comment

by:sosinc3
ID: 33730894
SBS 2003 technically does not need forwarders, however, if you want to use forwarders, after you made the changes, you need to restart the DNS Server service. Also, make sure the server itself is only looking to its own IP address for resolution. As a starter, however, I would remove the forwarders all together, restart the service, and test.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
LVL 7

Assisted Solution

by:supports
supports earned 668 total points
ID: 33730922
i agree with sosinc.. u dont need forwarders
0
 

Author Comment

by:rick60
ID: 33730957
I'll try removing the forwarders... but just curious...  how then does the SBS know where to get external DNS information?
0
 
LVL 7

Expert Comment

by:supports
ID: 33730963
dns are generally in ur router configuration,
0
 
LVL 39

Assisted Solution

by:ChiefIT
ChiefIT earned 664 total points
ID: 33731022
In forwarders, you can put in your router's IP address...

Most ISP's dynamically provide you an IP address to the outside interface of your router. If so, theywill put in their DNS server's dynamically.

If you disable recursion and remove all forwarders IPs, your DNS server will default to an iterative query and root hints.

It's best to configure forwarders with either your router's IP or your ISP's DNS servers. You should be able to see the ISP's DNS server's IP addresses by logging onto the router and checking out the DNS servers that are dynamically passed down.

By saying your DNS doesn't need forwarders is only a partial truth. It does need a designated IP. That could be root hints with recursion disabled, your ISP's DNS servers directly using recursion, or your router's IP that will query your ISP's DNS servers with a recursive lookup.  
0
 
LVL 5

Accepted Solution

by:
sosinc3 earned 668 total points
ID: 33731592
Do not put anything in forwarders. SBS uses the root DNS servers for domain resolution.
0
 

Author Comment

by:rick60
ID: 33734976
I solved the problem of it not working at all...  Turned out that my router still had the programming in it to route a static IP to/from the server for VPN.  When I changed ISP's, the static IP was no longer being routed here on the WAN side.  Deleting the static routes did the trick.
But all of you helped solve a long-standing problem I've had regarding DNS lookups and clearing the farwarders fixed that!  So...  ended up fixing a problem I was'nt even working on..  Thanks to everyone.
0
 
LVL 5

Expert Comment

by:sosinc3
ID: 33735225
Rick, of course I am glad you fixed your issue but I am wondering why you split the points the way you did? What I told you to do is what Microsoft even recommends for SBS. Anyway, I guess you can't buy much with points at the store so I am not worried about it. I am a little confused about your comment also. If you have a static route, it would impact everything going/coming from that IP address so more than DNS should have not been working from the server - even browsing on the internet, mail routing, etc. Good job finding the problem.
0
 

Author Comment

by:rick60
ID: 33735597
sosinc3, You are correct...  I was not able to get the SBS to surf the net or ping a url or anything...  yet the client computers, if not using the SBS for DNS, were working great.  I thought the reason the SBS was not able to hit the WAN was due to DNS failure, but obviously that turned out to not be the case.  But it did'nt dawn on me what the real issue was until I tried to ping the ISP's DNS IP on the SBS.... and it failed.  Then I realized I had something blocking the server from hitting the WAN.  Questions was...  what's in the system that treats the server differently than the clients?  Bingo...  the static routes for VPN.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Numerous times I have been asked this questions that what is it that makes my machine log on so slow, there have been cases where computers took 23 minute exactly after taking password and getting to the desktop. Interesting thing was the fact th…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question