?
Solved

Exchange Command Shell Filters for Mailenable Public Folders

Posted on 2010-09-21
28
Medium Priority
?
757 Views
Last Modified: 2012-06-27
Does anyone know the command line to make the mail enables folders in public folders show up in the public folders address list?
0
Comment
Question by:funkyone60
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 7
  • 5
  • +1
28 Comments
 
LVL 15

Expert Comment

by:vahiid
ID: 33731799
They should show up in your Public Folders address list after every update interval. If the update is not running or you want to run a manual update, run this command:

Update-AddressList "Public Folders"


You'll get some details about your "Public Folders" address list by running

Get-AddressList "Public Folders" | FL


Vahid
0
 

Author Comment

by:funkyone60
ID: 33732004
i don;'thave a public folders address list on the exchange server- I hace contacts/rooms/groups/GAL- no public folders-when I go to add address list- no public folders to choose from
0
 
LVL 15

Expert Comment

by:vahiid
ID: 33732043
Run the Get-AddressList cmdlet in exchange management shell to see if the Address List is missing in your Exchange.

If you are missing it, or it is created on an older version of Exchange, run:

Set-AddressList “Public Folders” –RecipientFilter {RecipientType –eq “PublicFolder”}

This will convert the address list  to Exchange Server 2010.

Vahid
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:funkyone60
ID: 33732170
heres what I shows- and then when I run your command line
public-folder.JPG
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33733228
you need to run the Enable-MailPublicFolder cmdlet

Enable-MailPublicFolder "\foldername"
0
 

Expert Comment

by:subratd
ID: 33734212
this is the command to set the Public Folder address list:

Set-AddressList "Public Folders" -RecipientFilter {RecipientType -eq "PublicFolder"}

Can you try this is some other server?
0
 

Author Comment

by:funkyone60
ID: 33735605
what do u mean?  like run that command from the dc?
0
 

Expert Comment

by:subratd
ID: 33746215
not from DC..
If you are running it from Mailbox server ,.. then try to to run it from HUB or CAS server.
:)
0
 

Author Comment

by:funkyone60
ID: 33746664
i dont have a HUB or CAS server-
0
 

Author Comment

by:funkyone60
ID: 33749912
ok- the public folders is showing up but if you hit the drop down in address book and select public folders it shows you the GAL on the public folders address list
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33750014
i am going to get my lab back online and get what you need
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33750088
are you still in mixed mode with exchange 2003?
0
 

Author Comment

by:funkyone60
ID: 33750385
no I am not
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33750417
did you run this command from the exchange management shell
it will prompt you to upgrade the address list

Set-AddressList "Public Folders" -RecipientFilter {RecipientType -eq "PublicFolder"}

0
 
LVL 15

Expert Comment

by:vahiid
ID: 33750529
This is actually going to sound wierd, but you can't always copy and paste commands in powershell and except them to work. This cmdlet is one of them!

So if the copy and paste still gives you the same error, just type in the command word by word in your exchange powershell and it will work fine:

set-addresslist "Public Folders" -RecipientFilter {(RecipientType -eq 'PublicFolder')}


Vahid
0
 

Author Comment

by:funkyone60
ID: 33750577
ok- when I typed this command in it brought be to >>with flashing cursor- should I type something else or hit enter
0
 
LVL 15

Expert Comment

by:vahiid
ID: 33750626
That simply means the syntax is still incorrect, press Ctrl+C to get out of the >> mode and double check the command. If it helps, copy and paste into notepad and then type in power shell from notepad, paying attentions to ' and "
0
 

Author Comment

by:funkyone60
ID: 33754945
are those parentheses or arrows on the inside of -->{(RecipientType -eq 'PublicFolder')}
0
 

Author Comment

by:funkyone60
ID: 33755147
now it is actually bringing me back to the command prompt- should there be dialog after I run the command?
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 2000 total points
ID: 33755179
no, that should be all

you can test the result of this by running
Get-Recipient -Filter { RecipientType -eq 'PublicFolder' }
0
 

Author Comment

by:funkyone60
ID: 33755367
it shows the correct folders but when I go to public folders in my drop down menu in in outlook- still shows the GAL.  Its not the bigeest deal in the world but its one of those buggy little things that make me crazy.
0
 
LVL 15

Expert Comment

by:vahiid
ID: 33756126
Try it in OWA and see if you see the right Public Folder list. If OWA works fine, then it's your Outlook Profile. Try taking it off the cache mode, or rebuild outlook profile.
0
 

Author Comment

by:funkyone60
ID: 33756845
Great idea but yes its the same in owa.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33756893
you don't see the public folders list at all
0
 

Author Comment

by:funkyone60
ID: 33757364
i see the list but the contents are the GAL
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33757440
sounds like your ldap filter for this list is off
run the following to check

get-addresslist public* | fl name,ldap*

it should look like
(& (mailnickname=*) (| (objectCategory=publicFolder) ))
0
 

Author Comment

by:funkyone60
ID: 33757552
this is what it came back as
ldap.JPG
0
 

Author Closing Comment

by:funkyone60
ID: 33757888
I think maybe it took a minute for the seetings to replicate- but it worked- Thanks for your help!!
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question