• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3882
  • Last Modified:

setting user acess to ECP in Exchange 2010 OWA

I am convinced now that no one can access ECP in OWA becuase of permissions- where do you setup user rights and access to ECP for exchange 2010 OWA
0
funkyone60
Asked:
funkyone60
  • 7
  • 5
  • 2
  • +1
1 Solution
 
e_aravindCommented:
what is the error message @ the IExplorer screen
- any other details at the application-logs
0
 
Ahmed ShahbaSystem ArchitectCommented:
Hi,
Did you make any user migration or move or modify any permission?
Regards,
Ahmed
 
0
 
endital1097Commented:
you should run
set-ecpvirtualdirectory ecp* -basicauthentication:$true -windowsauthentication:$true

then go into iis manager, default web site and select the ecp vdir
open authentication settings
ensure that anonymous is enabled
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
funkyone60Author Commented:
editi all- how do I undo those changes?  I get the login page but it takes me to 404 page- when I put those settings in it said I must make the same changes to the owa vd- which I did- now i can access the site
0
 
endital1097Commented:
to undo change the $true to $false

post the results for
get-ecpvirtualdirectory | fl
get-owavirtualdirectory | fl
0
 
Ahmed ShahbaSystem ArchitectCommented:
Hi,
go to Exchnage console >Server Configuration>Client Access in right hand side ; check Authentication tap on ECP and configure it same as Outlook WebApp (owa) authentication.
Regards,
 
0
 
funkyone60Author Commented:
here are the settings now- I have not changed anything back yet
ecp.JPG
0
 
endital1097Commented:
those settings look good, did you compare to the owa vdir to ensure they matched

owa by default has fba enabled
0
 
funkyone60Author Commented:
owa before changes back
owa-pt-1.JPG
0
 
funkyone60Author Commented:
before changes back
owa-pt-2.JPG
0
 
endital1097Commented:
they both look proper, the 404 is page not found

did you go into owa and try the options?
look in the iis logs for the /ecp entry
there should be more info for the 404
0
 
funkyone60Author Commented:
what should the virtual directory default setting be?  after I ran those 2 commands about seeting the virtual directory it stopped running pass the login page
0
 
endital1097Commented:
are you getting a blank page?
0
 
funkyone60Author Commented:
http 400 after login page
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 7
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now