• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1542
  • Last Modified:

Cannot start VM due to missing hard disk drive

I'm running VMs on ESXi 4 platform. one of my VMs ran into issues due to HDD corruption and now i cannot start the VM. I get the error message
virtual disk 'Hard Disk2' is not accessible on the host:unable to access the file []servername/server.vmdk
I tried to remove the offending harddrive editing the VM settings but i get the message
invalid configuration for device 0.
What do i do?
1 Solution
Try creating another new VM without the disks and then manually add the disks you need linked to the files formerly used by the faulty VM.
adjaddyAuthor Commented:
thanks, 1oo4.
is there no way i could remove references to this drive? and try booting the VM?
You can try editing  <VM_name>.vmx file directly on your datastore.
In your case you will probably have to delete all entries related to scsi:0.1
Were you running on a snapshot?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now