Mailflow problems with Exchange 2003 & 2010 Coexistence

I recenlty introduced a new Exchange 2010 server into my existing exchange 2003 environment.  My only issue is when sending mail from a mailbox on the 2003 server to a test mailbox on the 2010 server.  Messages sent in any other direction are working properly.

I inherited a single exchange 2003 server environement with an Ironport appliance facing the public side for mail relay and antispam/antivirus.
For some reason the messages being sent from the 2003 mailbox to the 2010 mailbox are getting hung up in the routing group connector queue (automatically created when 2010 was installed).  The 2003 mailbox will receive a delivery status notification delay with a 4.4.7 message from my exchange 2003 server.  I've checked the mail logs on my Ironport and found that the messages are actually being sent to the Ironport instead of directly to my exchange 2010 server.  I believe this is because my exchange 2003 server is sending the message out on the default SMTP virtual server after it sees that the mailbox is not local to the 2003 server. The default SMTP virtual server is set to forward to my Ironport.  Is there anyway to get around this?  I only have 1 nic/IP setup on the exchange 2003 server now, so I can't setup a second SMTP virtual server.

Exchange 2003 is running on windows server 2003 sp2
Exchange 2010 (rollup 4) is running on windows server 2008 sp2
My AD forest is at a 2003 functional level, but the resource domain that the exchange servers are in is windows server 2008 enterprise sp2 w/2 DC's that are both Global Catalog servers.

Any help would be greatly appreciated.

Who is Participating?
Glen KnightConnect With a Mentor Commented:
There are a couple of reasons for this the first of which will be a smarthost configured in the Defualt SMTP Virtual Server on the Exchange 2003 server.
Check out my article here for some options:
Glen KnightConnect With a Mentor Commented:
sorry I didn't see the part of your question where you indicated this was an issue.

You would need to setup an SMTP Connector (under connectors) however, as long as you have the Send Connector (under Organisation Configuration > Hub Transport) configured to go to your ironport the exchange 2003 server will route mail through here.
endital1097Connect With a Mentor Commented:
the most likely cause is the settings on your default smtp virtual server for the 2003 server
check for a smart host configuration for outbound messages

you will need to create an smtp connector with the address space of * using the smart host for delivery and the default smtp vs as the bridgehead
once that connector is in place you can remove the smart host from the virtual server
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

once you verify that you can deliver a message to 2010
you could use the send connector on 2010 for outbound messages and remove the smtp connector
Glen KnightCommented:
All endital did was repeat my posts, were my posts not helpful?
stoltzhelpdeskAuthor Commented:
demazter:  your posts were helpful, but I felt endital1097 comments were easier to understand and more complete.  thanks again for the quick responses.
>> i was typing as demazter posted and didn't see his comment. seen this several times and that's why i posted
Glen KnightCommented:
You will find if you look at my second post and enditals first they are almost identical.  The problem is also explained in my article quite clearly.
Alan HardistyCo-OwnerCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.