Server 2008 not registering in DNS?

I don't receive any eventID errors after registering my Server 2008 R2 via ipconfig /registerdns.
The OS is pretty much RTM with the exception of running command "netsh int 6to4 state disabled" and some security template settings that have been working fine on other non R2 server.

There is no issues with 2003 servers or clients.

Is there any verbose logs I can look at or enable in the registry temperarily for troubleshooting?

Thanks again
snyderkvAsked:
Who is Participating?
 
luconstaConnect With a Mentor Commented:
snyderkv: You are right but I still check if the "Dynamic updates" are allowed "secure only" or "nonsecure and secure" because if your server is not "communicating securely" will not be allowed to register.

By the way - your DNS server is on Windows 2003 or 2008?...
0
 
willettmeisterCommented:
Do you have Register this connection's addesses in DNS checked?
0
 
Darius GhassemCommented:
In your TCP\IP settings make sure you are only pointing to internal DNS servers.
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
luconstaCommented:
Besides dariusg settings, you shoud also check the properties of your DNS server zone to allow "Dynamic updates" otherwise none of your DNS clients will register.
0
 
snyderkvAuthor Commented:
Oh yeah forgot to note the obvious. Yes I have that checked as well as pointing to local DCs for DNS.

Luconsta: but like I said, no other clients have issues. This is only Server 2008 R2 RTM.

Thanks for the help though. Any other suggestions please pass them by :)
0
 
Darius GhassemCommented:
Post ipconfig /all from server.
0
 
snyderkvAuthor Commented:
IPConfig shows nothing significant. Netbios is enabled and the DCs are pointing locally and resolve just fine. The server is joined to the domain.
0
 
snyderkvAuthor Commented:
DNS domain is 2003 native with schema extension for 2008 even though that doesn't really matter. We are non secure or (none) integrated.
0
 
snyderkvAuthor Commented:
That was the problem. Dynamic updates on the zone was set to None meaning, nobody will register updates haha. I set it to Secure and it worked. I found this out after mimicking the network within my VM and recreating the problem although it seems obvious now.
0
 
luconstaCommented:
By any chance snyderkv "figured out" after I recommend this in post #33734339 or after I've insisted on #33735112?...  :)
0
 
snyderkvAuthor Commented:
luconsta,

Whoa I just looked back and reread what you wrote and was exactly what the problem was. I read it earlier but was so tangled up on other things that I forgot that I had looked at that based off your post.

Thanks for resolving this for us.
0
 
luconstaCommented:
Your're welcome and thak you for the points.
Now you saw why is a good thing to double check even "obvious settings" because what you saw in your DNS records were only "stall records"... ;-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.