Solved

Visual Studio 2008 ASP.NET app. Crystal Report wont Load

Posted on 2010-09-22
10
656 Views
Last Modified: 2013-11-26
I can't seem to figure out why my crystal report within visual studio won't load. It does not make any sense to me as the report is sitting on the same server as where the app runs from and the report source is pointing to that report and I do have a viewer. When running this app on my local machine it seems to work fine, but when installed to the server it just gives me a "Load Report Failed"..

0
Comment
Question by:Jennifer Barman
  • 4
  • 4
  • 2
10 Comments
 
LVL 9

Expert Comment

by:wellhole
ID: 33734316
Make sure IIS has permissions to the report file. This could be as simple as adding your IIS anonymous user to the security settings on the file.
0
 

Author Comment

by:Jennifer Barman
ID: 33734464
What is IIS Anonymous user?
0
 
LVL 9

Expert Comment

by:wellhole
ID: 33734491
Check the website properties in IIS under the Directory Security tab.
0
 

Author Comment

by:Jennifer Barman
ID: 33734522
This is checked..


app001.jpg
0
 
LVL 9

Expert Comment

by:wellhole
ID: 33734540
Check your FILE.
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:Jennifer Barman
ID: 33734591
Should my crystal report be located in IIS? Just wondering as it is not.. I have my crystal web page.. which the source on the web page points to the report.. but the actual crystal report is not in IIS..
0
 
LVL 83

Expert Comment

by:CodeCruiser
ID: 33734619
Crystal Reports require access to the Temp Files folder on the server.
0
 
LVL 83

Accepted Solution

by:
CodeCruiser earned 500 total points
ID: 33734633
0
 
LVL 9

Expert Comment

by:wellhole
ID: 33734721
CodeJennifer, the IIS anonymous user must have access permissions to the file itself. Can you confirm that in the security settings in the file property?
0
 

Author Closing Comment

by:Jennifer Barman
ID: 33734904
I found that I could not use the path that I had set.. I had to have it set to d:\... and not servername\d$\....
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
eclipse formatting 6 41
ASP.NET Web Form Variables being reset 2 18
C# Error - Add Failed 12 39
XML & .net 5 19
For those of you who don't follow the news, or just happen to live under rocks, Microsoft Research released a beta SDK (http://www.microsoft.com/en-us/download/details.aspx?id=27876) for the Xbox 360 Kinect. If you don't know what a Kinect is (http:…
Wouldn’t it be nice if you could test whether an element is contained in an array by using a Contains method just like the one available on List objects? Wouldn’t it be good if you could write code like this? (CODE) In .NET 3.5, this is possible…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now