Solved

Visual Studio 2008 ASP.NET app. Crystal Report wont Load

Posted on 2010-09-22
10
667 Views
Last Modified: 2013-11-26
I can't seem to figure out why my crystal report within visual studio won't load. It does not make any sense to me as the report is sitting on the same server as where the app runs from and the report source is pointing to that report and I do have a viewer. When running this app on my local machine it seems to work fine, but when installed to the server it just gives me a "Load Report Failed"..

0
Comment
Question by:Jennifer Barman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
10 Comments
 
LVL 9

Expert Comment

by:wellhole
ID: 33734316
Make sure IIS has permissions to the report file. This could be as simple as adding your IIS anonymous user to the security settings on the file.
0
 

Author Comment

by:Jennifer Barman
ID: 33734464
What is IIS Anonymous user?
0
 
LVL 9

Expert Comment

by:wellhole
ID: 33734491
Check the website properties in IIS under the Directory Security tab.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Jennifer Barman
ID: 33734522
This is checked..


app001.jpg
0
 
LVL 9

Expert Comment

by:wellhole
ID: 33734540
Check your FILE.
0
 

Author Comment

by:Jennifer Barman
ID: 33734591
Should my crystal report be located in IIS? Just wondering as it is not.. I have my crystal web page.. which the source on the web page points to the report.. but the actual crystal report is not in IIS..
0
 
LVL 83

Expert Comment

by:CodeCruiser
ID: 33734619
Crystal Reports require access to the Temp Files folder on the server.
0
 
LVL 83

Accepted Solution

by:
CodeCruiser earned 500 total points
ID: 33734633
0
 
LVL 9

Expert Comment

by:wellhole
ID: 33734721
CodeJennifer, the IIS anonymous user must have access permissions to the file itself. Can you confirm that in the security settings in the file property?
0
 

Author Closing Comment

by:Jennifer Barman
ID: 33734904
I found that I could not use the path that I had set.. I had to have it set to d:\... and not servername\d$\....
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question