Solved

Not getting reply from a ping to the OSPF multicast address

Posted on 2010-09-22
36
1,310 Views
Last Modified: 2012-05-10
I’m adding a numbers of routers to the OSPF setup of the network. I tried to add one of the routers using a different area than 0 but the new router status keeps saying INIT/DROTHER. The other router shows the information from the routers that are already part of OSPF but no information from the new router. Since the other routers are working fine with area 0 I decided to try adding the new router to area 0 but I got the same INIT state problem. I started to troubleshoot the configuration and everything looked fine with the output from:

sh ip ospf int
debug ip ospf events
debug ip ospf adj – (this one didn’t shows any data)

The MTU is also fine on both routers and no ACLs or authentication is in use on any of the routers.

Then I check doing a ping to the multicast address 224.0.0.5 in the routers that were already working and got a reply to each of the interfaces IP address with OSPF. When I did the same thing at the new router I got just one single period.

CB# ping 224.0.0.5

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:
.
CB#

So the ping to the OSPF multicast is not working in the new router. Please advice what to do in this case.


Here is the new router’s config:

version 12.4
!
hostname CB
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip cef
!
no ip dhcp use vrf connected
!
ip multicast-routing
!
interface Loopback1
 ip address 10.200.204.1 255.255.255.224
!
interface GigabitEthernet0/0
 description LAN Interface
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no mop enabled
!
interface GigabitEthernet0/0/0
 ip address 10.10.1.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 network 10.10.1.0 0.0.0.3 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 10.10.1.1 permanent
0
Comment
Question by:ecajigas
  • 18
  • 17
36 Comments
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Please post the config of the two routers in question.
0
 

Author Comment

by:ecajigas
Comment Utility
version 12.4
!
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
!
hostname IG
!
no aaa new-model
!
resource policy
!
no ip source-route
ip cef
ip tcp synwait-time 10
!
interface Loopback1
 ip address 10.200.200.1 255.255.255.0
!
interface GigabitEthernet0/0
 description LAN Interface
 bandwidth 1048576
 ip address 192.168.10.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no mop enabled
!
interface GigabitEthernet0/1
 description to CCTV1
 ip address 172.10.1.1 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip pim dense-mode
 ip virtual-reassembly
 ip route-cache flow
 ip ospf cost 10
 ip ospf hello-interval 1
 ip ospf dead-interval 2
 ip ospf retransmit-interval 3
 ip ospf transmit-delay 3
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no mop enabled
!
interface GigabitEthernet0/1/0
 description Service Provider Fiber Link
 no ip address
 negotiation auto
!
interface GigabitEthernet0/1/0.10
 description to CCTV2
 encapsulation dot1Q 10
 ip address 172.10.2.1 255.255.255.252
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip ospf hello-interval 1
 ip ospf dead-interval 2
 ip ospf retransmit-interval 3
 ip ospf transmit-delay 3
 no snmp trap link-status
 no cdp enable
!
interface GigabitEthernet0/1/0.32
 description to CB
 encapsulation dot1Q 32
 ip address 10.10.1.1 255.255.255.252
 no snmp trap link-status
 no cdp enable
!
router ospf 1
 log-adjacency-changes
 network 10.10.1.0 0.0.0.3 area 0
 network 172.10.1.0 0.0.0.3 area 0
 network 172.10.2.0 0.0.0.3 area 0
 network 192.168.10.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
How are IG and CB connected? They're going through a switch?

Can IG successfully ping 10.10.1.2?


0
 

Author Comment

by:ecajigas
Comment Utility
IG and CB are connected with an ethernet link provided by a telco. They use MPLS but it is transparent for us. CCTV#2 is also connected to IG with another VLAN and it is working fine. CB and IG  did work using static routes. IG can ping 10.10.1.2 without problems and viceversa CB can ping 10.10.1.1 just fine.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Then I would suspect that the telco is doing something like blocking the multicast.

You could try statically defining the OSPF neighbor on the two routers. (neighbor 10.10.1.1)
0
 

Author Comment

by:ecajigas
Comment Utility
The command returns that I can only use it on non-broadcast multiple access or point to multipoint netowrks.  From IG config you can see the interface that connects to CCTV#2. I'm using the same service provider for that link and I have no adjacency problems and I can ping the multicast address. As you can see in the config I'm using dot1q so I'm receiving CB and CCTV#2 on the same circuit but with different vlans.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Please post the output (using the "code" feature please) of a "show ip ospf interface" for the interfaces of both routers that connect to each other.

0
 

Author Comment

by:ecajigas
Comment Utility

IG#sh ip os in g0/1/0.32

GigabitEthernet0/1/0.32 is up, line protocol is up

  Internet Address 10.10.1.1/30, Area 0

  Process ID 1, Router ID 10.200.200.1, Network Type BROADCAST, Cost: 1

  Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 10.200.200.1, Interface address 10.10.1.1

  No backup designated router on this network

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:07

  Supports Link-local Signaling (LLS)

  Index 5/1, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 0, maximum is 0

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 0, Adjacent neighbor count is 0

  Suppress hello for 0 neighbor(s)



CB#sh ip ospf int g0/0/0

GigabitEthernet0/0/0 is up, line protocol is up

  Internet Address 10.10.1.2/30, Area 0

  Process ID 1, Router ID 10.200.204.1, Network Type BROADCAST, Cost: 1

  Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 10.200.204.1, Interface address 10.10.1.2

  No backup designated router on this network

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:05

  Supports Link-local Signaling (LLS)

  Index 1/1, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 0, maximum is 0

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 1, Adjacent neighbor count is 0

  Suppress hello for 0 neighbor(s)

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
All the parameters look good.

Both routers are showing as DR which indicates they don't see each other (no surprise there).

One thing that is curious is that CB is showing one neighbor while IG is showing none.

What neighbor is CB seeing?


0
 

Author Comment

by:ecajigas
Comment Utility

CB#sh ip ospf neigh



Neighbor ID     Pri   State           Dead Time   Address        Interface

10.200.200.1      1   INIT/DROTHER    00:00:36    10.10.1.1      GigabitEthernet0/0/0

CB#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
That's what I suspected. The hellos from IG are arriving at CB, but the hellos from CB are not making it to IG.

I would debug the ospf hellos at CB and confirm the hellos are going out.
0
 

Author Comment

by:ecajigas
Comment Utility
don,

That's what I told in the first post. The output from debug ip ospf events shows that hello messages are going back and forth in both routers. The only wrong thing that I found was that CB cannot ping 224.0.0.5. Please check my first post. The debug ip ospf adj shows nothing of course. I will later port the output from the debug command for you to check it out.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
>That's what I told in the first post.

Actually, there is no mention of the word "hello" in the original post.

So just to confirm:

CB is sending (and receiving from IG) OSPF hellos?

And IG is sending (and receiving from CB) OSPF hellos?


0
 

Author Comment

by:ecajigas
Comment Utility
I'm sorry you are right, my mistake here are all the outputs:


==========================================================================================



IG SHOW OSPF NEIGHBORS



IG#sh ip os ne



Neighbor ID     Pri   State           Dead Time   Address         Interface

172.10.10.1      10   FULL/DR         00:00:01    172.10.1.2      GigabitEthernet0/1

172.10.3.1        1   FULL/BDR        00:00:01    172.10.2.2      GigabitEthernet0/1/0.10

IG#



=========================================================================================



IG OSPF EVENTS



IG#debug ip ospf events

OSPF events debugging is on

IG#

2294210: Sep 22 23:01:09.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1/0.10 from 172.10.2.1

2294211: Sep 22 23:01:09.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1 from 172.10.1.1

2294212: Sep 22 23:01:09.475 GMT: OSPF: Rcv hello from 172.10.3.1 area 0 from GigabitEthernet0/1/0.10 172.10.2.2

2294213: Sep 22 23:01:09.475 GMT: OSPF: End of hello processing

2294214: Sep 22 23:01:09.579 GMT: OSPF: Rcv hello from 172.10.10.1 area 0 from GigabitEthernet0/1 172.10.1.2

2294215: Sep 22 23:01:09.579 GMT: OSPF: End of hello processing

2294216: Sep 22 23:01:10.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1/0.10 from 172.10.2.1

2294217: Sep 22 23:01:10.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1 from 172.10.1.1

2294218: Sep 22 23:01:10.475 GMT: OSPF: Rcv hello from 172.10.3.1 area 0 from GigabitEthernet0/1/0.10 172.10.2.2

2294219: Sep 22 23:01:10.475 GMT: OSPF: End of hello processing

2294220: Sep 22 23:01:10.579 GMT: OSPF: Rcv hello from 172.10.10.1 area 0 from GigabitEthernet0/1 172.10.1.2

2294221: Sep 22 23:01:10.579 GMT: OSPF: End of hello processing



==================================================================================================================



CB DEBUG OSPF EVENTS



CB#debug ip ospf events

OSPF events debugging is on

CB#terminal monitor

CB#

Sep 22 2010 23:05:21.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0/0 from 10.10.1.2

Sep 22 2010 23:05:21.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0 from 192.168.1.1

Sep 22 2010 23:05:22.286: OSPF: Rcv hello from 10.200.200.1 area 0 from GigabitEthernet0/0/0 10.10.1.1

Sep 22 2010 23:05:22.286: OSPF: End of hello processing

Sep 22 2010 23:05:31.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0/0 from 10.10.1.2

Sep 22 2010 23:05:31.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0 from 192.168.1.1

Sep 22 2010 23:05:32.286: OSPF: Rcv hello from 10.200.200.1 area 0 from GigabitEthernet0/0/0 10.10.1.1

Sep 22 2010 23:05:32.286: OSPF: End of hello processing

Open in new window

0
 
LVL 1

Expert Comment

by:lomoalapimienta
Comment Utility
Typical MPLS VPNs do not provide multicast support. OSPF protocol needs multicast so you may use some kind of tunneling between both sides, using GRE for example.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
There's your problem. IG is NOT sending hellos out the g0/1/0.32 interface.

All we have to do now is figure out why.

If it were me, I would delete the OSPF process (on IG) and recreate it.

And I prefer specific network statements (not that it should make any difference in this case). I would use:

network 192.168.10.1 0.0.0.0 area 0
network 172.10.1.1 0.0.0.0 area 0
network 172.10.2.1 0.0.0.0 area 0
network 10.10.1.1 0.0.0.0 area 0


0
 

Author Comment

by:ecajigas
Comment Utility
The problem that I have at this specific moment is that IG is in production. I will have to check when to do the change then. In the menatime can you please explain the change in wildcards?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
A quad zero wildcard mask means "only this address" (will be classified as an OSPF interface/network).

While your configuration will work, most people configuring OSPF use a 0.0.0.0 mask.


0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:ecajigas
Comment Utility
Understood!

Here, for your consideration,  is the config and debug from CCTV#2 (3550 IOS 12.2) that is also connected to IG and is working fine (by the way IG 3825 advanced security 12.4(7c) - CB same router/IOS). Also the PING to multicast from IG and CCTV#2:


======================= 3550 CCTV#2 =============================



hostname CCTVSW2

!

no errdisable detect cause pagp-flap

no errdisable detect cause dtp-flap

no errdisable detect cause link-flap

no errdisable detect cause l2ptguard

no errdisable detect cause gbic-invalid

no errdisable detect cause loopback

ip subnet-zero

ip routing

ip multicast-routing

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

 switchport mode access

 no ip address

 spanning-tree portfast

*

*

*

*

*

interface FastEthernet0/24

 description to CCTV#3

 no switchport

 ip address 172.10.3.1 255.255.255.252

 ip ospf hello-interval 1

 ip ospf dead-interval 2

 ip ospf retransmit-interval 3

 ip ospf transmit-delay 3

!

interface GigabitEthernet0/1

 description provider link to IG

 no switchport

 ip address 172.10.2.2 255.255.255.252

 ip ospf hello-interval 1

 ip ospf dead-interval 2

 ip ospf retransmit-interval 3

 ip ospf transmit-delay 3

!

router ospf 27

 router-id 172.10.3.1

 log-adjacency-changes

 network 172.10.2.0 0.0.0.3 area 0

 network 172.10.3.0 0.0.0.3 area 0

!

ip classless

end



======================================================================================



CCTV#2 OSPF NEIGHBORS



CCTVSW2#sh ip ospf neigh



Neighbor ID     Pri   State           Dead Time   Address         Interface

172.10.4.1       10   FULL/DR         00:00:01    172.10.3.2      FastEthernet0/24

10.200.200.1      1   FULL/DR         00:00:01    172.10.2.1      GigabitEthernet0/1

CCTVSW2#



=====================================================================================



CCTV#2 DEBUG OSPF EVENTS



CCTVSW2#term monitor

CCTVSW2#debug ip ospf events

OSPF events debugging is on

CCTVSW2#

000061: Sep 22 20:38:41.927 GMT: OSPF: Rcv hello 10.200.200.1 area 0 from GigabitEthernet0/1 172.10.2.1

000062: Sep 22 20:38:41.927 GMT: OSPF: End of hello processing

000063: Sep 22 20:38:42.619 GMT: OSPF: Rcv hello 172.10.4.1 area 0 from FastEthernet0/24 172.10.3.2

000064: Sep 22 20:38:42.619 GMT: OSPF: End of hello processing

000065: Sep 22 20:38:42.927 GMT: OSPF: Rcv hello 10.200.200.1 area 0 from GigabitEthernet0/1 172.10.2.1

000066: Sep 22 20:38:42.927 GMT: OSPF: End of hello processing

000067: Sep 22 20:38:43.619 GMT: OSPF: Rcv hello 172.10.4.1 area 0 from FastEthernet0/24 172.10.3.2

000068: Sep 22 20:38:43.619 GMT: OSPF: End of hello processing

000069: Sep 22 20:38:43.927 GMT: OSPF: Rcv hello 10.200.200.1 area 0 from GigabitEthernet0/1 172.10.2.1

000070: Sep 22 20:38:43.927 GMT: OSPF: End of hello processing



========================================================================================================



IG PING TO MULTICAST



IG#ping 224.0.0.5



Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:



Reply to request 0 from 10.10.1.2, 4 ms

Reply to request 0 from 10.200.200.1, 1 ms

Reply to request 0 from 172.10.1.2, 1 ms

Reply to request 0 from 172.10.2.2, 4 ms

IG#



=========================================================================================================



CCTV#2 PING TO MULTICAST



CCTVSW2#ping 224.0.0.5



Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:



Reply to request 0 from 172.10.3.2, 1 ms

Reply to request 0 from 172.10.2.1, 4 ms

CCTVSW2#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Just out of curiosity, what model router's are CB and IG?
0
 

Author Comment

by:ecajigas
Comment Utility
IG and CB are both 3825 running advanced security 12.4 (7c).  I got a window to reset the OSPF process from IG. I saved the OSPF config, remove it completly, check that there were no OSPF routes, paste the OSPF commands back, and IG quickly established the adjacencies with CCTV#1 and #2 but not with CB.
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
Comment Utility
And IG is still not sending OSPF hellos out the G0/1/0.32 interface?

If that's the case, there's only one thing I can think of before opening a case with TAC.

Reboot the IG router. I know it sounds far-fetched, but with all the "features" that have been added to the IOS over the years, a reboot will sometimes fix an unfixable problem.


0
 

Author Comment

by:ecajigas
Comment Utility
There are no hellos out of G0/1/0.32

I will schedule the full boot after working hours. If that fails I will go with a backup router to CB site to connect it back to back with CB and take the provider link out of the equation.

I will let you know.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Thanks. This is definitely weird.

But then again, I recall a known issue on the 3550's where sometimes they would not build adjacencys. The only way to get it working was a reboot.

Go figure. :-p
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
I just thought of something else.

I could be an issue with the sub-interface. If you can, before the reboot, remove all configurations from the .32 sub-interface. Then create a new sub-interface (.33) and configure it and see if that works. If it doesn't, then bounce the router.
0
 

Author Comment

by:ecajigas
Comment Utility
don,

I didn't hard boot the router but reload it and the ospf didn't work. Then I get the idea to use a Tunnel interface instead of going to CB site (is a 2 hour car trip), to connect another router back to back.

CB got full routing table from IG

IG did not receive all the routes from CB

Well partially, CB got full routing tables from IG,  CB shows up as a neighbor and viceversa, . But... (there's always a but),  IG didn't receive the routes from CB except for tunnel interface and loopback interface IP's segment.  

CB shows up as a neighbor in IG once but the state says " FULL / - "

IG shows up as a neighbor in CB twice:

CB#sh ip os ne

Neighbor ID      Pri   State                  Dead Time    Address         Interface
10.200.200.1      0   FULL/  -               00:00:38     10.10.1.1       Tunnel3
10.200.200.1      1   INIT/DROTHER    00:00:38     10.10.1.1       GigabitEthernet0/0/0
CB#


0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
The "FULL/ - " is normal on a point-to-point interface.

Did you try creating a new sub-interface? Something is preventing the hellos...
0
 

Author Comment

by:ecajigas
Comment Utility
No I could'nt, that will be my next step then.

In the mean time I contacted the service provider to check if everything is ok from their side (something wrong with their MPLS/switch configuration, etc.)

I'll let you know.
0
 

Author Comment

by:ecajigas
Comment Utility
Wow! I completly miss lomoalapimienta post. My apologies

Lomo you are right with the tunnel but IG is not getting all the routes only the one for the tunnel and the loopback. I contacted my service provider to check this. Weird thing is that I have another router with the same provider over the same service (received on a different vlan) and I didn't need to use tunnels for OSPF to work with that router.
0
 

Author Comment

by:ecajigas
Comment Utility
Lomo, I verified the events for hellos at IG and CCTV#2 (the other router) and IG is sending and receiving hellos to/from the sub-interface that connects to the other router with the same service from the provider. What could be the cause for it to work with one sub-interface/vlan and not the other?

And again I'm sorry for missing your post.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
I had seen the tunnel idea but it didn't explain why one path would work and not the other. Besides, the reason this is not working is because IG is not sending hellos out the .32 sub-interface. The question (for me at least) is why.

0
 

Author Comment

by:ecajigas
Comment Utility
Ok the provider game me confirmation that they are not adding anything with the MPLS or VLANS and that they have many clients running OSPF without problems. Now the status with the tunnel change to EXSTART and then it says too many retries and change the status to DOWN.

I re-created g0/1/0.32 but it didn't work. I'm gonna move to CB site next Tuesday. In the mean time I will keep the link active with static routes.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
How did you recreate the .32 interface? In order to truly remove it, you have to delete it and reboot the router. If you don't want to take that path, simply create another sub-interface and apply the commands to that one.
0
 

Author Closing Comment

by:ecajigas
Comment Utility
A reload did not work neither turning off the router by switch. I had to remove the power cable wait a couple of seconds and plug it back.
0
 

Author Comment

by:ecajigas
Comment Utility
Recreating the sub-interface with or without the same name didn't work either. I had to unplug CB and plug it back and everything works.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Power cycling the router fixed it.

I hate it when that happens! Cisco routers have now achieved parity with Windows PC's. :-o
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now