Solved

How to I configure Internet  failover on cisco 1700 router

Posted on 2010-09-22
3
865 Views
Last Modified: 2012-05-10
Hi all hopefully someone can help me with this problem.
I have 2 Internet connections  and Ciso 1700 router. I need to configure the router  so that  i have a primary link and a backup.  The network will have  2VLANS  1 voice and 1 data.
WHat needs to happen is this.

If the primary link goes down it automatically routers traffic of the  backup.
0
Comment
Question by:thombie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 33734612
Assuming you are not running a routing protocol with your providers, you need to use static routes with object tracking.

http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html


0
 
LVL 24

Accepted Solution

by:
rfc1180 earned 500 total points
ID: 33736104
additional, if you are planning on using NAT, you will also need PBR:  Here is an example:

hostname Router
!

ip cef

!####Establish sla monitors for use in tracking objects####!

ip sla monitor 1
  type echo protocol ipIcmpEcho 12.34.45.1
  threshold 3
  frequency 5

ip sla monitor schedule 1 life forever start-time now

ip sla monitor 2
  type echo protocol ipIcmpEcho 23.34.56.1
  threshold 3
  frequency 5

ip sla monitor schedule 2 life forever start-time now

!

!####Configure Tracking objects (referencing IP SLA monitor’s above)####!

track 101 rtr 1 reachability
!
track 102 rtr 2 reachability
!
!
!
!
!####Configure Interfaces with NAT####!

interface FastEthernet0
  ip address 192.168.1.254 255.255.255.0
  ip nat inside
!
interface s0/0
  ip address 12.34.45.2 255.255.255.0
  ip nat outside
!
interface s0/1
  ip address 23.45.67.2 255.255.255.0
  ip nat outside
!
ip classless

!####Configure gateway of last resort with tracking objects####!
ip route 0.0.0.0 0.0.0.0 12.34.45.1 track 101
ip route 0.0.0.0 0.0.0.0 23.45.67.1 track 102

!####Configure NAT statements for most outbound traffic####!
ip nat inside source route-map ISP1 interface s0/0 overload
ip nat inside source route-map ISP2 interface s0/1 overload

!####Configure NAT statements for your mail server####!
!(remember to setup dns for mail on both public IP addresses)!

ip nat inside source static tcp 192.168.1.10 25 12.34.45.2 25 route-map ISP1 extendable
ip nat inside source static tcp 192.168.1.10 25 23.45.67.2 25 route-map ISP2 extendable
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!####Configure route maps for reference in NAT statements####!

route-map ISP2 permit 10
  match ip address 10
  match interface s0/1

!
route-map ISP1 permit 10
  match ip address 10
  match interface s0/0
!

Billy
0
 

Author Closing Comment

by:thombie
ID: 34203333
Sorry for the delay I have been away for long while.
0

Featured Post

MIM Survival Guide for Service Desk Managers

Major incidents can send mastered service desk processes into disorder. Systems and tools produce the data needed to resolve these incidents, but your challenge is getting that information to the right people fast. Check out the Survival Guide and begin bringing order to chaos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Setting up a VPN 60 207
Internet Protocol Security question 3 117
Cisco 3560 Switch with Multiple Gateways 10 83
Receiving wifi on an underground station 22 130
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question