LDAP query to Active Directory

I have a Barracuda Spam firewall that is setup to perform LDAP lookups against AD to ensure that recipient names are valid.  However, that ability has somehow stopped and I'm not sure why.   Specifically, it was sending these queries to our Exchange server at port 389 (I believe).  At first I thought something must have gone wrong with the Barracuda and so I called tech support, however, after I was unable to telnet to port 389 and 3268 from within my network, I was told that the problem was with the Exchange server.  

What do I need to change to get this Exchange server to respond to LDAP requests (or telnet connections on those ports)?
tballinAsked:
Who is Participating?
 
Joseph DalyConnect With a Mentor Commented:
I think you wouldnt be making an LDAP connection to your exchange server but rather one of your domain controllers. Try making a connection on port 389 to one of your DCs.
0
 
Mkris9Commented:
With barracuda, the LDAP query always should go to the DC. if you have one server where your exchange server itself is your DC, then yes, it has to go to your exchange server.

Else it has to go to your DC. also Barracuda is normally set up on the DMZ. Pls check your firewall for DMZ > LAN settings and see if LDAP port is allowed and to which server
0
 
afinneranCommented:
Unless you have AD running on your Exchange box I wouldn't think it would be handling the LDAP calls. Like xxdcmast said try to telnet to 389 on your DC. Also, if it just stopped working it could be security related. Any patches/ changes added to Barracuda or your DC's lately?
0
 
tballinAuthor Commented:
Well, I know I HAD it setup to go to my Exchange server, and it WAS working before.  Whatever the case though, xxdcmast's solution worked.  (And he was the first, so I'll give him the points)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.