• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3075
  • Last Modified:

Ordinal 423 could not be located in the dynamic link library urlmon.dll

I am getting this error message.  I do not have the Windows XP CD and my other CPU's run windows 7 so I cannot copy the urlmon.dll file.  Is there another fix.  No prompts come up in windows
0
JoshJones
Asked:
JoshJones
  • 7
  • 7
  • 2
1 Solution
 
optomaCommented:
Re/Install IE8
http://www.microsoft.com/windows/internet-explorer/worldwide-sites.aspx

If needed, download it on another machine to transfer.
0
 
acl-puzzCommented:
i can mail u my  urlmon.dll from xp sp2 it can help whats urs mail-id?
0
 
JoshJonesAuthor Commented:
Can you please mail it to josh@beancountersonline.com?

Can you walk me through what I need to do to get it on that PC.  The only thing that comes up is a blank screen with no taskbar and no windows icons.  If I press the windows button, nothing happens
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
optomaCommented:
As mentioned above. Download IE8 and save it on a removable device.

Boot the affected machine onto safe mode with command prompt>type   "explorer" without quotes.

Browse to IE8 installer and install.

Reboot and problem should be resolved :)
0
 
JoshJonesAuthor Commented:
I cannot get a command prompt in safe mode.  Nothing shows up on my screen in safe mode
0
 
acl-puzzCommented:
i will mail u that after that u need to remove/rename and then paste it in c:\windows\system32  and then register it like this REGSVR32  C:\Windows\System32\urlmon.dll but let me know what else this pc having problems?

use F8 key during stratup and choose "Safe mode with command prompt"

but iam still not sure what exactly happended there u didnt mentioned anything except that dll file in urs question

0
 
JoshJonesAuthor Commented:
I was downloading windows updates along with explorer version 8.  After the reboot, I started to get this message.  I do not get anything in regular windows.  I brought up safe mode with the command prompt and currently having "C:/Documents and Settings\Adminstrator" on the screen
0
 
acl-puzzCommented:
"currently having "C:/Documents and Settings\Adminstrator" on the screen"

just type explorer there and do wht has been suggested
0
 
JoshJonesAuthor Commented:
Thank You - How will I past the file to c:\windows\system32  ?

When I type explorer, I get the error message again.
0
 
acl-puzzCommented:
u got any pen drive with u? just copy into it and do exactly as suggested just give it a try..and i think u may also need o use system restore if it doesnt work simply paste this in command propmt

%systemroot%\system32\restore\rstrui.exe

and revert system state to previous time when everything was working fine
0
 
JoshJonesAuthor Commented:
Ok - This still does not seem to be working.  I did not receive your file, but I downloaded explorer 8 to my pen drive, put it in the usb port and typed explorer.  I just ended up getting the error message again
0
 
acl-puzzCommented:
i mailed u that already anyways it seems it has more problems then i expected so pls system restore type this

%systemroot%\system32\restore\rstrui.exe

and revert system state to previous time when everything was working fine

or use this easy tutorial follow only first three pictures there!

http://www.theeldergeek.com/system_restore.htm

do it and post and let it run and after that post the result

0
 
JoshJonesAuthor Commented:
I get a blank white windows box that says system restore at the top
0
 
acl-puzzCommented:
can u attach a screenshot(when u restart system restore)using print screen keyboard key then pasting into paint?
0
 
JoshJonesAuthor Commented:
I am not sure how I would get the screenshot from that cpu.  It doesnt have any applications that will come up.  I am on my desktop and the problems are occuring on my laptop
0
 
acl-puzzCommented:
hmm ok i think u need to uninstall all windows updates as nothing seems to be working there so use this command to open add remove programs


C:\Documents and Settings\Administrator>appwiz.cpl
after that check the boz which says "show updates" and uninstall all updates and also uninstall IE after removing updates restart this computer and if still nothing works download and install  this utilty and click on "care" button and let it run and reboot the pc

http://download.cnet.com/Advanced-SystemCare-Free/3000-2086_4-10407614.html

take yours time and after doing above post the results

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

  • 7
  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now