Solved

"The server is unavailable" accessing exchange 2003 via vpn using outlook 2k7 or 2k10.

Posted on 2010-09-22
14
761 Views
Last Modified: 2012-05-10
Using two way vpn connections (sonicwall to sonicwall). I am able to ping exchnage and map drives to network. Outlook accepts the exchange account (confirms account name/resolves exchange server name) upon creation, but when I try to launch outlook I get "The server is unavailable". All ip-to-host name entries in local host file for the remote network are present and correct. Can someone please help me resolve this?

Thanks,
Evan
0
Comment
Question by:ekitech
  • 6
  • 3
  • 3
  • +1
14 Comments
 
LVL 5

Expert Comment

by:darrylka
ID: 33736806
Are you trying to use (RPC) over HTTP?
0
 

Author Comment

by:ekitech
ID: 33736949
Thanks for your reply darrylka. Is that OWA? I'm not familliar with RPC over HTTP.
0
 
LVL 5

Expert Comment

by:darrylka
ID: 33736987
RPC over HTTP allows remote Outlook users to connect to an Exchange Server (Exchange 2003 and above) over an HTTP connection without the need for a VPN connection.  It's how Exchange became a hostable solution.
0
 
LVL 12

Expert Comment

by:FDiskWizard
ID: 33737010
Sounds like your firewall is blocking Exchange <> Outlook traffic. Can you check your logs?
See this for list of ports used:
http://technet.microsoft.com/en-us/library/bb124075(EXCHG.65).aspx

Also try simply browsing to the exchange server.
\\Exchange_server\

Maybe it is a DNS/WINS issue.
But since you said you pinged it (by name?) probably not - unless the name is resolving to the wrong IP.

0
 

Author Comment

by:ekitech
ID: 33737012
really, can you direct me to a link that will help me set that up? Does it use the OWA URL as the smtp and pop servers?
0
 

Author Comment

by:ekitech
ID: 33737110
Firewall was turned off. I am able to access the server via \\Exchange_server\. DNS is ok.
0
 
LVL 12

Expert Comment

by:FDiskWizard
ID: 33737166
Maybe you're running into an MTU issue.
Try this... an MTU tweak that has helped us with some Outlook clients in the past.
http://support.microsoft.com/kb/315008
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:ekitech
ID: 33737286
Thanks FDiskWiz. I'm running Windows 7 Enterprise. Your link is for xp.
0
 
LVL 5

Expert Comment

by:darrylka
ID: 33737359
Yes, it uses the OWA URL.  Here's an excellent article about how to set it up:

http://www.msexchange.org/tutorials/Implementing-RPC-over-HTTPS-single-Exchange-Server-2003-environment.html
0
 
LVL 15

Expert Comment

by:JBond2010
ID: 33737586
Setting up RPC/HTTP is not neccessary as you have a VPN in place.

>>Configured lower mtu, is that 1500 ? Have you tried with 1300 ?

Try this below first;

1. Lower the mtu on the remote computer (choose one, again the end computer and not the gateway) to be 1300

How to do this? Google Dr.tcp and get the tiny tool. Use that to set the mtu on the machine to 1300 to the correct adaptor.

2. Then go to 'hosts' file Windows\System32\Drivers\etc, make a static entry for this server.

See if that helps.

0
 
LVL 12

Expert Comment

by:FDiskWizard
ID: 33737825
Ah, you're right.. people are saying that reg tweak doesn't work in Vista/Windows7
Now you can do it via NETSH
netsh interface ipv4 set subinterface "Local Area Connection" mtu=nnnn store=persistent
Follow the numbers in that article and try those values in place of nnnn
0
 

Author Comment

by:ekitech
ID: 33738340
ID:33737359 Author:darrylka - Figure 5 in your link calls for changing data in registry key (see attached). I tried this key with: MyExchangeServerName.MyDomain.com as shown in the attached image and it didn't work, should this be the OWA URL instead? webmail.MyDomain.com (this info is also required in Fig. 8 (see attached) in your link)

BTW I'm using Outlook 2010, Exchange 2003 Ent. I have also used Outlook 2007 with same problem

Tried MTU without success and HOST file already has entry for exchange server/all servers.
Figure-2051156860528218-1-.jpg
image0161156762532484-1-.jpg
0
 
LVL 15

Accepted Solution

by:
JBond2010 earned 500 total points
ID: 33740242
Follow this link and see does it help. It applies to Outlook 2007 & Outlook 2010.

http://support.microsoft.com/kb/913843
0
 

Author Closing Comment

by:ekitech
ID: 33887786
Don't know if this is the solution or not. Been too busy to work on it but thanks.
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OpenVPN is a great open source VPN server that is capable of providing quick and easy VPN access to your network on the cheap.  By default the software is configured to allow open access to your network.  But what if you want to restrict users to on…
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video discusses moving either the default database or any database to a new volume.

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now