Windows 7 Network issue

Posted on 2010-09-22
Last Modified: 2012-05-10
I have just purchased a new Dell pc for a client's home with Windows 7 Professional (32 bit) installed. After installing some basic apps (office/skype/itunes to name a few), I have a problem that occurs. The symptoms are, internet explorer will not open (shows as running in task manager), the network icon in the taskbar has the rotating 'egg-timer' on it and reports no network connection - however, I have been diagnosing using LogMeInRescue so there's obviously a connection working to some extent! Also, the network and sharing center doesn't open to add to the case for a network issue of some sort.
I can successfully use system restore to go back a day or two and the problem is again ok but soon re-appears (within 24 hours). I checked the event logs and saw a few warnings/errors relating to a printer driver which I have since removed but the problem is still there. I've run a full scan using avg in safe mode with no problems reported.
Any ideas please?
Question by:nigelr99
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
LVL 15

Expert Comment

by:Jeff Perkins
ID: 33737399
Could be a malware issue, AVG won't pick up everything. First thing to do is run malwarebytes, the free version, do a full scan after updating.  If you aren't familiar with this you can get it at:

If still no joy, go to and in the upper right corner download hijackthis.  Run that and save the log file.  You can attach the log file here and I'll have a look at it for you.

Author Comment

ID: 33737651
Thanks for the reply.
I scanned with malwarebytes - no poblems.
I scanned with hijackthis and have attached the logfile.
I've also examined the system event log and there's lots of errors there such as on the screenshot attached.

Author Comment

ID: 33737658
Please note - I performed the scans after a recent system restore; not when the problem was happening.
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  


Expert Comment

ID: 33739249
It looks like one of your windows services isn't starting up.  Check all the listed services in the event viewer and make sure they or their dependancies are running.  For example, the error highlighted above says that the workstation service needs the Network Store Interface Service to start.  So go to Start -> Run, and Type "services.msc", and go to the Network Store Interface service.  If it isn't running, try right clicking it an starting it.  If it still won't start up, try running the system file check, you might have a corrupt service file.

LVL 15

Expert Comment

by:Jeff Perkins
ID: 33742692
Ditto to Russell's comment.  I did not see your hijackthis log, you can also evaluate that at
It would probably prove even more helpful to scan when the service is down, but there may be some trace of the bad guy in there even after doing restore. Obviously if that is what is causing this, something stays behind, or someone is visiting an infected location to re-aquire it.

Accepted Solution

nigelr99 earned 0 total points
ID: 33789658
Sorry for delay - only just had access to pc again.
I ended up sort of struggling with the services trace etc. and a malware scan when the problem was evident again gave no warnings. System services check also gave no errors still.
So in the interests of time, I did an upgrade install from the dvd. It seems to have fixed the issue.
It looks like the server service was the main problem in the event log but I'm at the age where I haven't got the time to question these things for too long :-). Thanks for your help, not really sure what to do with points so open to suggestions!
LVL 15

Expert Comment

by:Jeff Perkins
ID: 33789840
Doesn't seem like anything I suggested helped, without reading through the posts again, my suggestion would be you solved your own question.... so ask for refund and have the question PAQ'd for anyone with similar problem in the future.
   Unless someone else objects....

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question