Solved

Not prompted for password on Cisco UC520 via SSH

Posted on 2010-09-22
6
909 Views
Last Modified: 2013-12-27
I have a UC520,  I've created users on it via CLI, set the Enabled/Secret passwords etc.. yet when I SSH in I can literally just type in any username for any user that exists on the system and it logs me right in to #.  It doesn't even prompt for a password.   This is obviously a huge security risk and being a bit hesitant to post my config and leave some identifying information in it I'm hoping that someone could point me in a direction.

0
Comment
Question by:ZooyorQ
  • 3
  • 3
6 Comments
 
LVL 3

Expert Comment

by:uniplast
ID: 33741237
You can give different privileges to users that you define.
At this link is explained in detail how it works

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t13/feature/guide/ftprienh.html
0
 

Author Comment

by:ZooyorQ
ID: 33741266
So if I lower the privilege to say 1 from its current 15 users will be prompted with a password to access privileged commands?
0
 
LVL 3

Expert Comment

by:uniplast
ID: 33741292
Yes, but  lowest level of access is 0
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:ZooyorQ
ID: 33741826
Even with a high privilege shouldn't the user be prompted for their password though?
0
 
LVL 3

Accepted Solution

by:
uniplast earned 500 total points
ID: 33741998
Login Authentication Using Enable Password

Use the aaa authentication login command with the enable method keyword to specify the enable password as the login authentication method. For example, to specify the enable password as the method of user authentication at login when no other method list has been defined, enter the following command:

aaa authentication login default enable


Before you can use the enable password as the login authentication method, you need to define the enable password. For more information about defining enable passwords, refer to the chapter "Configuring Passwords and Privileges."

More about this is on link
http://www.cisco.com/en/US/docs/ios/12_2/security/configuration/guide/scfathen.html
0
 

Author Comment

by:ZooyorQ
ID: 33746511
The solution was changing the aaa authentication default to enable, it was currently set to none.  Thanks!
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The Zaptel people (www.zaptel.com) got kind of annoyed with the fact that they were getting bombarded with searches for the zaptel driver system for Asterisk (not to mention they own the trademark on zaptel). So, they kindly requested that Digium ch…
As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question