[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

2TB Limit with Server 2008 R2 X64 Raid 5 Array

Posted on 2010-09-22
8
Medium Priority
?
5,129 Views
Last Modified: 2012-05-10
Server Specs:
IBM x3620 M3 with 8x 2TB SAS drives with a ServeRAID M5015 SAS/SATA Controller.

Earlier this week I had configured a RAID 5 array using the LSI MegaRaid config wizard in the bios. I used all 8 drives in a  RAID 5 volume.

I then preceded to install Windows Server 2008 R2 x64 onto that array. When I booted into the Operating System - I shrunk the C:/ drive from 12.53 TB to 100 GB and then used the remaning space as a Backup Drive (V:). Everything was working fine.

Today i had a change of plans and decided to create 2 RAID 5 arrays (each with 4x2tb drives).

I then attempted to install Windows Server 2008 R2 x64 onto the first array. Once i entered into the OS i noticed that i only had access to 1.99 TB of data. The rest of my array was unusable and unavailable. I could not extend/expand the array - or create new volumes with it.

The send new 4x2tb array that i created was not the OS drive - and i was able to convert that to a dynamic/GPT disk so that all of the 5.5TB was usable.

MY QUESTION: Why am i now limited by the 2TB limit? I do not think that i did anything different with the setup this time. I am confused because earlier this week I had server 2008 R2 x 64 using the entire 12.5 TB array with (8x2TB) drives - now, using the same drives - just in different arrays - i am only able to access 2Tbs.

Any ideas?

Thanks!
0
Comment
Question by:RavenInd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
8 Comments
 
LVL 33

Expert Comment

by:PowerEdgeTech
ID: 33740998
Server 2008, 2008R2, Vista, 7 cannot boot to a larger than ~2TB volume unless installed on UEFI-enabled system.
0
 
LVL 47

Accepted Solution

by:
David earned 1000 total points
ID: 33741094
The constraint was always there ... MSFT does not support bootable disk > 2.09TB unless you have an itanium-based system (or UEFI).  The difference is BOOTABLE.
0
 

Author Comment

by:RavenInd
ID: 33743733
How was it that i had it booted before than? I was booting to a 12.5 TB Drive on a 100GB partition... I do also remember there being a EFI System partion or something along those lines with the first install...
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 47

Expert Comment

by:David
ID: 33744637
I object closing for zero. His question was asked, and answered by two experts correctly.  I will add that an array, volume, and partition are different things.  Booting to a 100GB partition is different then booting to a volume or disk.  To make it easier to understand, let me just say that windows won't let you boot to a C: drive that is > 2.09 TB. the 100GB partition is C:, so it worked. In light of the additional info, author clearly tried to make the 4x2GB array into a "C" drive.  This will not work.
0
 
LVL 33

Assisted Solution

by:PowerEdgeTech
PowerEdgeTech earned 1000 total points
ID: 33744900
Agreed.  I thought that by pointing out the boot partition size limit, that it would be apparent to you why the first install worked and the second did not, because the with the first one, you created a 100GB partition, which is fine, and the second install only saw 1.99TB for the C partition, because that is all it can handle (non-EFI).
0
 
LVL 33

Expert Comment

by:PowerEdgeTech
ID: 33744986
I think splitting the points would have been more appropriate, but thank you for not simply closing the question.
0
 
LVL 47

Expert Comment

by:David
ID: 33748419
thx everybody.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question