• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 709
  • Last Modified:

Sharing folders on Windows Server 2008

Hello,

I created a new folder on a Windows server 2008 and Im not able to share it to only one user. I checked the Shared permissions and gave the user Full Control as well as in the Security Rights. Im not even able to go inside the folder but I am able to see it. Now, if I give permission rights to the Everyone or Autenticated Users groups, Im able to go inside the folder, create and delete files....

Why cant I only give rights to one user? What are my doing wrong?

Any ideas?

Thanks!
0
ArgTech
Asked:
ArgTech
  • 5
  • 4
  • 2
1 Solution
 
ATLTEKCommented:
Is the user a member of a specific security group other than the default 'users'
0
 
ArgTechAuthor Commented:
The user is part of all the default security groups. It is a new server.
0
 
ATLTEKCommented:
domain or workgroup?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
ArgTechAuthor Commented:
Domain. It is actually a SBS 2008
0
 
ATLTEKCommented:
ah, SBS 2008. I've had my share of headaches with those..
Are you able to share any other folders? I'm assuming nope.
Here is a great guide to Server 2008 folder sharing with screenshots and all. Works the same for SBS 2k8
http://www.techotopia.com/index.php/Configuring_Windows_Server_2008_File_Sharing

0
 
ArgTechAuthor Commented:
Will look into that link. Im only able to share folders but for everyone, not for only one user. Can't beleive Im even asking about how to do this...

Thanks
0
 
ATLTEKCommented:
nothing like relearning something you've been able to do a million times before :)
darn wizards.
0
 
Krzysztof PytkoSenior Active Directory EngineerCommented:
so, sharing folder in Windows require setting up 2 levels of permissions: share (works over network) and security (works locally). The most restrictive set wins.

A good practice says that: share should be set to everyone or authenticated users as "Full control" or "Contributors rights".
Security tab (NTFS permissions) should be adjusted as you need with the most restrictive rights.

Example:

I would like to share folder MyData for johns (modify) and someperson (read-only). No more people.

I will share folder and on:

share tab everyone(full access/control)

security tab: johns (modify), someperson (read&execute)

Check it that way :)
0
 
ArgTechAuthor Commented:
Sorry but still no luck. Im only able to access the folder when I give permission and securioty rights to the Everyone or Authenticated Users Groups.
I created a security group for that user only and it didnt work either.
Never seen something like this...
0
 
Krzysztof PytkoSenior Active Directory EngineerCommented:
That's very strange :/ Can you take a print screen(s), please?
0
 
ArgTechAuthor Commented:
Sorry I didnt get back to you hguys that were helping me with this. It turned out to be a problem on the user that I was testing with. I had to recreate the user and everythign worked fine.

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now