Emails being delayed (exchange 2010)

Posted on 2010-09-23
Medium Priority
Last Modified: 2012-05-10
Hello All .

after i upgrade my exch env to SP1.

I have 2 MBX+HUB , 2 CAS + 1 EDGE , this is my exchange ENV , we have another email system
and they are share the my domain name-space (xyz.com) through INTERNAL RELAY on exchange :
all messages destined to the exchange ENV are getting delayed for more than 50 min , i search all the queues on the exchange and the other ENV and found nothing , finally all message are received but they are delayed .
the tracking log  show me corrected  info .
i need to know how to troubleshoot this problem correctly and on the proper order .
thanks alot
Question by:Exchisa
  • 2
  • 2
  • 2

Expert Comment

by:Jamie Gillespie
ID: 33742146
Create a new SMTP connector to test. Are emails getting to the correct destination even after the delay?

Expert Comment

by:Jamie Gillespie
ID: 33742168
I would also check the Exchange Event logs and use http://www.mxtoolbox.com/ to check whether you may be blacklisted.

Author Comment

ID: 33742936

This is Internal issue , both servers are located on my internal network , it's not related to the IP blacklist ,  all emails are finally received , but they get delayed for one hour .
forefront protection is installed on the edge server , i note that my edge server processor get more than 90 % and eat most of my memory , the service responsible for that is the forefront services , i disabled most forefront services , now the message gets faster than before .
what do u think my problem is ?
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

LVL 26

Expert Comment

by:Tony J
ID: 33752102
I would run the best practices analyzer and see if it can find any problem.
LVL 26

Expert Comment

by:Tony J
ID: 33752130
Also are the mails between users on different mailbox servers? How are they set up?

Are you mailbox and CAS servers in separate locations (as in do you have one MBX & CAS in one location and one MBX and CAS in another)?

Are you having any routing and/or replication issues within AD?

Does the problem exist in both directions?

Why are your internal mails passing through an Edge server?

I would still run a blacklist check at www.mxtoolbox.com just to rule it out.

Accepted Solution

Exchisa earned 0 total points
ID: 33820986
I stop the FFP for Exchange and solved the delay problem .

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

I am posting this in case anyone runs into similar issues that I did, this may save you a lot of grief: Condition: 1. Your NetBIOS domain name contains an ampersand " & " character.  (e.g. AT&T) 2. You've tried to run any Microsoft installation…
You have missed a phone call. The number looks like it belongs to the bunch of numbers which your company uses. How to find out who has just called you?
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
In this video I will demonstrate how to set up Nine, which I now consider the best alternative email app to Touchdown.

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question