Solved

MSA500 can't access logical drives

Posted on 2010-09-23
5
662 Views
Last Modified: 2012-05-10
I'm a cluster newbie and have a cluster array that was taken offline and stored for a few months. Inevitably we need some data off of it and one of the cluster Nodes has a failed Raid controller for the OS partition so no-boot. The other node can boot to Windows 2000 but cannot access any of the 3 logical drives even though they are visible within the HP tools as well as Windows Explorer. I have that so close yet so far feeling.
0
Comment
Question by:VendorExpertsExchange
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 11

Accepted Solution

by:
willettmeister earned 250 total points
ID: 33745952
When you say they cannot access the drives what do you mean.  They are not accessable to the cluster?  

I think that it's possible from your description that the cluster thinks that another node has control of the drives.  

Open up the cluster admin tool and see if you node has the resources online and available to the node you need to access the data from.
0
 

Author Comment

by:VendorExpertsExchange
ID: 33746445
In Windows explorer I can see drives D, L and Q (assuming this is for Quorum) but when I double click I get a message that the drive is not accessible and the device is not ready.

I probably should've included this in the opener but I cannot get the cluster service to start so I cannot access the cluster admin either.

Is there a way to bypass the cluster requirement?
0
 
LVL 11

Expert Comment

by:willettmeister
ID: 33753551
How is your data stored?  is it on an SAN or some sort.  If so take all you cluster nodes offline and present the data to a non cluster aware machine as a first step.
0
 
LVL 55

Assisted Solution

by:andyalder
andyalder earned 250 total points
ID: 33769241
willettmeister is on the right track, I think all you have to do is to set Clusdisk driver to disabled and restart since it's that service that's making the disk appear offline. http://support.microsoft.com/kb/280425/ relates although it#s about a slightly different problem.
0
 

Author Closing Comment

by:VendorExpertsExchange
ID: 33810610
Ultimately I don't know what did it. My vendor for this particular app did some work on the machine then asked that I bring it online with the DC. It worked but I totally appreciate your help and knowledge so I've giving out partials.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The 6120xp switches seem to have a bug when you create a fiber port channel when you have a UCS fabric interconnects talking to them.  If you follow the Cisco guide for the UCS, the FC Port channel will never come up and it will say that there are n…
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question