Solved

Installing Backup Exec 2010R2 remote agent failing.

Posted on 2010-09-23
6
4,452 Views
Last Modified: 2013-12-01
I am having an extremely hard time getting the Backup exec remote agent to install on my Exchange server or any remote server for that matter. My media server install went flawless, all services are running. I'm assuming it's a permissions issue. I have beat my head on this for two days.

Media server:
Microsoft Windows Storage Server 2008 STD SP2 x64
Symantec Backup Exec 2010R2

Remote Server: Exchange 2010)
Microsoft Exchange Server 2010

I've tried pushing the remote agent from the media console, I've tried using the remtote agent utility and I've copied the RAWSx64 to the remote machine and running it local. I keep getting the same error log.

Symantec Backup Exec Remote Agent (TM) 13 Installation Log

09-23-2010,12:22:52 : Windows Operating System Version: 6.0
09-23-2010,12:22:52 : GetProductInfo returned success. Checking for CORE OS values.
09-23-2010,12:22:54 : Executing managed _Setup:
09-23-2010,12:22:54 : E:\New Folder\RAWSX64\install\_Setup.exe
09-23-2010,12:22:54 : Loading XML from:
09-23-2010,12:22:54 : E:\New Folder\RAWSX64\install\IFProducts.xml
09-23-2010,12:22:54 : ArgsDataParser::InitDictionary
09-23-2010,12:22:54 : AgentSeqDlgs::RawsDlgSequence
09-23-2010,12:22:54 : Set RAWS Media path: E:\New Folder\RAWSX64\install\media\
09-23-2010,12:22:54 : RawsDlgSequence::CheckInstMode
09-23-2010,12:22:54 : BEOperations::BE_GetInstalledProdCodeVersion()
09-23-2010,12:22:54 : BEOperations::BE_GetInstalledProdCodeVersion()
09-23-2010,12:22:54 : Terminal Services enabled.
09-23-2010,12:22:54 : Terminal Services server has been set to Install mode.
09-23-2010,12:22:54 : Launching UI Install
09-23-2010,12:22:54 : Running in Installation mode
09-23-2010,12:22:54 : AgentSeqDlgs::ADlgWelcome
09-23-2010,12:22:54 : AgentSeqDlgs::ADlgInstallType
09-23-2010,12:22:54 : RawsDlgSequence::CheckInstalledProducts
09-23-2010,12:22:54 : BEOperations::BE_GetInstalledProdCodeVersion()
09-23-2010,12:22:54 : BEOperations::BE_GetInstalledProdCodeVersion()
09-23-2010,12:22:54 : AgentSeqDlgs::DlgChooseCustom
09-23-2010,12:22:54 : AgentSeqDlgs::ADlgPublishRemoteSrv
09-23-2010,12:22:54 : AgentSeqDlgs::AdlgInstallComplete
09-23-2010,12:22:54 : AgentSeqDlgs::Misc_BE_CommonOps
09-23-2010,12:23:10 : Create a Transform
09-23-2010,12:23:16 : Local Install Agent
09-23-2010,12:23:20 : AgentSeqDlgs::ReadAdvertiseListKey
09-23-2010,12:23:36 : AgentSeqDlgs::ReadAdvertiseListKey
09-23-2010,12:23:36 : 192.168.1.65;
09-23-2010,12:23:37 : AgentSeqDlgs::AgentInstaller
09-23-2010,12:23:37 : Starting Install
09-23-2010,12:23:37 : WARNING: Failed to copy .MST file to MSI cached folder.
09-23-2010,12:23:37 : In GetVMWareGuest().
09-23-2010,12:23:37 : RAWS MSI Command Line: EXE_ENVOKED=1 ALLUSERS=1 REBOOT=ReallySuppress INSTALLDIR="C:\Program Files\Symantec\Backup Exec\RAWS" INSTALLLEVEL=100 ADDLOCAL=VFF,VSSPROV,RANT64 TRANSFORMS="C:\ProgramData\Symantec\Backup Exec\{DA6F5B77-0DE2-4EE8-A07D-2B5E2B9429C3}\1033.MST" RAWSADVRTISENAMELIST=192.168.1.65; ENABLEADVRT=1 PATCH="" VMWAREGUEST = 0 INSTALLUIMODE=1
09-23-2010,12:23:37 : Running Install Mode
09-23-2010,12:23:37 : AgentInstaller::Install_Product_Thread
09-23-2010,12:23:37 : Launching MSI: E:\New Folder\RAWSX64\install\media\Symantec Backup Exec Remote Agent for Windows Systems.msi
09-23-2010,12:23:37 : Discovered Total Actions: 0
09-23-2010,12:23:37 : The return code from the MSI is: 2
09-23-2010,12:23:37 : AgentSeqDlgs::PostInstallActions
09-23-2010,12:23:37 : Cleaning up the symc status key
09-23-2010,12:23:37 : The return value for Symantec Backup Exec Remote Agent for Windows Systems returned error code: 2
09-23-2010,12:23:37 : Clean up Symantec installer keys.
09-23-2010,12:23:40 : AgentSeqDlgs::Misc_BE_CommonOps
09-23-2010,12:23:40 : The Installation Failed!


This happens no matter what server I attempt to install the remote agent on Server 2003 or 2008.
0
Comment
Question by:tdamon
6 Comments
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33747102
0
 

Author Comment

by:tdamon
ID: 33747186
I read that. No luck. I get that log file error when I try to install the remote agent locally on the remote server. I recieve another log file error when I try to push it. I've attache it in a file because it's very large.


exchange-Push.log
0
 
LVL 3

Expert Comment

by:tankmurdoch
ID: 33752370
Errors in that log suggest problem reading/writing to the registry. Try running the setup file manually again, only this time right-click and 'run as administrator'. I've had issues with certain program not working properly the 1st time as they need to be able to write to the registry and are unable to do so unless you do it this way.

Let me know...
0
 

Accepted Solution

by:
tdamon earned 0 total points
ID: 33758487
I found the problem. Corrupt media server installation. Reinstalled with Backup exec 2010 then applied the R2 update, remote servers install fine now.

Thanks
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 34740983
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

939 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now