IBM HTTP Server silent install failure

I'm a newbie, but I need to get my silent install working. Here's the error message I get at the bottom of the ihslog:

(Sep 21, 2010 11:55:17 AM), Process, com.installshield.wizardx.conditions.PlatformWizardBeanCondition, dbg.platform, condition platform: name="Windows .*" version="." arch="."
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ihs.ismp.actions.ISMPWarningDialogAction, wrn, setupAdminUser input field requires you to enter text.
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ni.ismp.actions.SettleNIFRegistryAction, msg1, Current install/uninstall process failed.
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ni.ismp.actions.SetExitCodeAction, msg1, CWUPI0000I: EXITCODE=1
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ni.ismp.actions.ISMPLogSuccessMessageAction, msg1, INSTCONFFAILED
jaerobAsked:
Who is Participating?
 
jaerobAuthor Commented:
Turns out I had an OS problem. The default temp directory needed to be explicitly set. Once I did that, the install went fine. Thanks so much for responding. :)
0
 
Frank ContrepoisVP Technical SalesCommented:
Do you have filled up the responsefile.txt file ?
0
 
Radek BaranowskiFull-stack Java DeveloperCommented:
youre probably missing

setupAdminUser  stanza in your response file

(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ihs.ismp.actions.ISMPWarningDialogAction, wrn, setupAdminUser input field requires you to enter text.

here's an example for complete response, for AIX (but doesn't differ for linux)

-OPT silentInstallLicenseAcceptance="true"
-OPT allowNonRootSilentInstall="true"
-OPT disableOSPrereqChecking="true"
-OPT installLocation="/usr/IBM/HTTPServer"
-OPT installGSKit="true"
-OPT httpPort="80"
-OPT adminPort="8008"
-OPT createAdminAuth="true"
-OPT adminAuthUser="ihsadmin"
-OPT adminAuthPassword="******"
-OPT adminAuthPasswordConfirm="******"
-OPT runSetupAdmin="true"
-OPT createAdminUserGroup="false"
-OPT setupAdminUser="ihsadmin"
-OPT setupAdminGroup="ihsadmin"
-OPT installPlugin="true" --optional--
-OPT webserverDefinition="<plugin instance config name>" --optional--
-OPT washostname="<was dmgr host you want to manage your IHS from>" --optional--


hope it helps
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.