Solved

IBM HTTP Server silent install failure

Posted on 2010-09-23
3
1,416 Views
Last Modified: 2013-12-10
I'm a newbie, but I need to get my silent install working. Here's the error message I get at the bottom of the ihslog:

(Sep 21, 2010 11:55:17 AM), Process, com.installshield.wizardx.conditions.PlatformWizardBeanCondition, dbg.platform, condition platform: name="Windows .*" version="." arch="."
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ihs.ismp.actions.ISMPWarningDialogAction, wrn, setupAdminUser input field requires you to enter text.
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ni.ismp.actions.SettleNIFRegistryAction, msg1, Current install/uninstall process failed.
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ni.ismp.actions.SetExitCodeAction, msg1, CWUPI0000I: EXITCODE=1
(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ni.ismp.actions.ISMPLogSuccessMessageAction, msg1, INSTCONFFAILED
0
Comment
Question by:jaerob
3 Comments
 
LVL 9

Expert Comment

by:fcontrepois
Comment Utility
Do you have filled up the responsefile.txt file ?
0
 
LVL 11

Expert Comment

by:Radek Baranowski
Comment Utility
youre probably missing

setupAdminUser  stanza in your response file

(Sep 21, 2010 11:55:17 AM), Process, com.ibm.ws.install.ihs.ismp.actions.ISMPWarningDialogAction, wrn, setupAdminUser input field requires you to enter text.

here's an example for complete response, for AIX (but doesn't differ for linux)

-OPT silentInstallLicenseAcceptance="true"
-OPT allowNonRootSilentInstall="true"
-OPT disableOSPrereqChecking="true"
-OPT installLocation="/usr/IBM/HTTPServer"
-OPT installGSKit="true"
-OPT httpPort="80"
-OPT adminPort="8008"
-OPT createAdminAuth="true"
-OPT adminAuthUser="ihsadmin"
-OPT adminAuthPassword="******"
-OPT adminAuthPasswordConfirm="******"
-OPT runSetupAdmin="true"
-OPT createAdminUserGroup="false"
-OPT setupAdminUser="ihsadmin"
-OPT setupAdminGroup="ihsadmin"
-OPT installPlugin="true" --optional--
-OPT webserverDefinition="<plugin instance config name>" --optional--
-OPT washostname="<was dmgr host you want to manage your IHS from>" --optional--


hope it helps
0
 

Accepted Solution

by:
jaerob earned 0 total points
Comment Utility
Turns out I had an OS problem. The default temp directory needed to be explicitly set. Once I did that, the install went fine. Thanks so much for responding. :)
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

This article is about some of the basic and important steps to be used to improve the performance in web-sphere commerce application development. 1) Always leverage the Dyna-caching facility provided by the product 2) Remove the unwanted code …
If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now