[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 258
  • Last Modified:

Transition from Exch2003 to Exch 2010 cannot connect with RPC over HTTP

HI,
We are transitioning an Organization from Exchange 2003 to Exchange 2010.
2003 is a Small Business Server, 2010 is running on Server 2008 R2 DataCenter.
Both servers are running. DNS has been updated for the new server. We have a proper certificate.
We cannot connect to using RPC HTTP/Outlook Anywhere.
Users on the LAN have no issues, we have users on both mail servers. They connect fine.
Has anyone else seen this problem, and possibly have a solution?
0
JamesCurrie
Asked:
JamesCurrie
  • 4
  • 3
  • 2
  • +1
2 Solutions
 
geieeaCommented:
You enabled Outlook Anywhere, right?
0
 
geieeaCommented:
Also, did you try using the testexchangeconnectivity.com. That will give you some more information.
0
 
endital1097Commented:
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
JamesCurrieAuthor Commented:
geieea
Outlook Anywhere is enabled. I will try the connectivity test.

endital1097
Thanks for the link, I will test as described.
0
 
JamesCurrieAuthor Commented:
HI Folks,
I have gotten to a point where when connecting to the 2010 Exchange server, it prompts for a password over and over. It doesn't make a difference which server the mailbox is on 2003 or 2010, it just prompts for a password, over and over.
Any thoughts?
Thanks
0
 
geieeaCommented:
Authentication methods are inconsistent or configure incorrectly.
0
 
JuusoConnectaCommented:
If Outlook Anywhere is enabled, on clients computer make sure the settings are correct:

Connect to Microsoft Exchange using HTTP (checked) ->
Exchange proxy Settings -> https://webmail.yourdomain.com (is written) ->
Connect using SSL only (checked) -> Only connect to proxy servers that have this principal name in their ceritifcate (checked) -> msstd:webmail.yourdomain.com ->
Set authentication to Basic


On the server side locate -> Exchange Management console -> Server Cofiguration -> Clien Access -> Properties of your exchange server -> Outlook Anywhere -> Make youre you have your external host name written here "webmail.yourdomain.com" and Basic authentication is Set.

Make also sure that under IIS (on the exchange), sub category owa has been set for basic authenticaion
0
 
JamesCurrieAuthor Commented:
Hi
Thanks for the replies. I have checked out most of the suggestions, it appears that possibly the certificate we have is not working as expected. We are in the process of obtaining a new certificate.
I will update once this is done.
0
 
JuusoConnectaCommented:
James,

If make sure that you order an SSL san ceriticate, there are several companiys that offers this, verisign among others
0
 
JamesCurrieAuthor Commented:
Fixing the certificate issue and using the answers from geieea and JuusoConnecta has resulted in a working Exchange server.
Thank you to all who made suggestions.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now