Solved

Hyperlinks not working in Visio 2003 when using Internet Explorer 2008 or 2007

Posted on 2010-09-23
7
942 Views
Last Modified: 2012-08-14
Hi All:

I'm having a problem that I'm sure has come up before but am unable to resolve related to Viso 2003 and hyperlinks. I have used Viso to create a file that is viewable in Internet Explorer 8 or 7 and the problem I'm having is the hyperlinks to other pages in the folder don't work when viewing with the Internet Explorer browser. I get "Internet Explorer cannot display the webpage" Now if I use hyperlink to get to a *bmp no problem it is only when linking to other pages and viewing using IE. Firefox works fine but I don't get the drop down and the ability to search the content. I have downloaded the SP3 patch for Visio which is supposed to address the problem with vml but it still doesn't work even after installing patch and rebooting and saving everything again. I even tried everything but vml under publish and what I get then when viewing the document via web page is an editable document and that I don't want either. Please excuse if this has been answered before. I'm so close to creating a useful document and this is the only thing holding me back.

Thanks
0
Comment
Question by:cp361
  • 4
  • 3
7 Comments
 
LVL 30

Expert Comment

by:Scott Helmers
ID: 33752772
Visio 2003 SP3 did solve some hyperlink problems... but it's been a while since I've played with it... seems to me there were a few lingering peculiarities...

Are you linking to a page or to an object on a page? Try the opposite to see whether the behavior is any different.

Can you recreate the problem with a simple two page drawing? If so, please post it here and I'll take a look at it.
0
 

Author Comment

by:cp361
ID: 33755456
OK I created new drawing ... initially it worked without  the drop down on the left and without search able content. but when I clicked on a shape it took me to the next page as it should.  I had not enable 'active x controls' .. Once I enabled active X controls the drop down appeared on the left side as well as the ability to search content. So it appears that enabling active x the problem but without enabling I won't see the cool search and drop down feature any suggestions? I will attach the simple example I used thanks.
Drawing1.vsd
0
 

Author Comment

by:cp361
ID: 33755511
Brother that was written badly let me try again.
I discovered after creating new file that as long as active X was not enable in IE I had no problem moving from one page to another in the simple example I attached. I clicked on the shape off to the second page it went. However without active x enabled I don't get the cool search able feature or the drop down. So I enable active x ,those features show up, but when I select the shape to go from one page to another I get and error "Internet Explorer cannot display the webpage" so it appears active X is the problem? But how do I work around it to get the cool features and be able to move from one page to another by selecting a shape?

Thanks
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 30

Accepted Solution

by:
Scott Helmers earned 500 total points
ID: 33774594
Found the problem...

What you've stumbled on is a quirk/bug/issue with Visio hyperlinks to another page in the same drawing. I know this is documented somewhere but let me just give you the short version:

Do NOT include the drawing name as part of the hyperlink when you are linking to another page in the same drawing.

I think you'll find that if you remove the drawing name from the Address field and republish, you'll be able to have your cake and eat it too... or I should say, have your hyperlinks and all the cool features too.

Scott
0
 

Author Comment

by:cp361
ID: 33775068
OK I think I know what you mean I will try tomorrow..In a nutshell just reference the page not the drawing of which the page is a subset. If it works you are my hero!
0
 

Author Comment

by:cp361
ID: 33785271
It worked !
Simple solution I don't know quite why it was so hard to find ;)

0
 
LVL 30

Expert Comment

by:Scott Helmers
ID: 33785354
Yeah -- totally non-intuitive but is a serious gotcha. I'm glad you have a solution... thanks for using EE.

Scott
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Have you ever created a custom Visio stencil – a collection of your own unique master shapes – and then created a drawing by dragging masters onto the drawing page? Have you then made changes to the stencil master and wondered why the shapes on the …
The ability to add structure to Visio diagrams using containers, lists and callouts is one of my favorite features in Visio 2010. In this article we’ll examine lists. We’ll explore containers and callouts in separate articles. Prior to reading th…
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now