Solved

2008R2 server internet download very slow

Posted on 2010-09-23
20
2,942 Views
Last Modified: 2012-05-10
I have a Windows 2008R2 36GB RAM, Intel Xeon processor server which does a couple of strange things, the first is using either 64bit or 32 bit IE8 (makes no difference) the download speed of files, or from websites, or speedtests from speedtest.net either fail as they are too slow and timeout, or are just so slow it makes things unworkable. Local network traffic performs normally. The problem only manifests itself when downloading from the internet.

The second issue is from time to time I have had a problem with the static IP when it first went into production after a few days it would not retain the IP it was given, this m,ay have been a teaming issue. So I broke the team and applied a single static IP. It appeared to be stable for a while but it decided quite randomly today to revert back to its previous IP address!!

Its running Websense email security and an EDM application, McAfee AV software.

I have changed the quad port NIC with no change, changed UTP patch cable, connected the server direct to the router, still no difference in the test results!!

Have 2 other servers similar spec but much much faster download speed, I have compared settings and changed where different, still no better.

Any ideas would be great, thanks experts.
0
Comment
Question by:npcinfo
  • 6
  • 6
  • 3
  • +3
20 Comments
 
LVL 7

Expert Comment

by:sirocco87
ID: 33749283
Try using a different browser and see if that works (e.g. portable Chrome)? Alternatively, try a different protocal such as FTP.
0
 
LVL 7

Expert Comment

by:namol
ID: 33749357
You say it's losing connectivity randomly, is the IP address some how being assigned to a different device on the network? IP conflicts can cause all the issues that you are describing.
0
 

Author Comment

by:npcinfo
ID: 33754211
Hi sirocco87 thanks for your reply. the ftp isn't offered by the sites I need to download from, I have 3 other servers (same model) on the network which all work normally. Some sites which need to be downloaded from do not use a browser.

Hi namol I discovered today that a printer on the network had grabbed the IP of the server so the server has reverted to what it was given originally. The IP was assigned manually so not sure how DHCP can re assign it?

I have a DHCP reservation which the server now falls into so its current IP should now be protected?

It still performs slowly even though its on a new static IP
0
 
LVL 7

Expert Comment

by:namol
ID: 33756296
You can assign an in use IP address to multiple devices, there is nothing that will stop you from doing that. I would change the IP address of the printer that you found to something else. Also, manually assign the server the reserved IP address that you set up in DHCP.

Have you tried running a speed test on the server to determine what the throughput might be? http://www.speedtest.net/
0
 

Author Comment

by:npcinfo
ID: 33769016
I left the printer with its newly assigned DHCP IP xxx.xxx.x.28. The server had gone back to its originally assigned static IP of xxx.xxx.1.8 so I have left it at that setting as it also falls outside of the range specified for distribution. The range not available for the DHCP pool is xxx.xxx.x.0 to xxx.xxx.x.21. The DHCP pool is xxx.xxx.x.22 to xxx.xxx.x.200.

I had a look at the allocation today and the printer that caused the problem the other day shows as having a DHCP address .12 in the pool, I have checked the printer using my browser and says it is on .28 (JetDirect network interface card). The MAC address information was included in the reservation when it was set up a few weeks ago. It seems to be ignoring its reserved IP.

Should I change the IP of the printer through my browser to match the previously setup reservation of .12?

I have been using speedtest.net as my benchmark sometimes it is so slow that you just get an error from speedtest and it fails to complete the test as it times out.
I tried it again just now and got the following results, I chose to test all with the London based server:
xxx.xxx.x.10 (Current DHCP server W2003 Std SP2, HP ML370 G4)
Download speed 4.82Mb/s, Up 5.49Mb/s, Ping 12ms
xxx.xxx.x.8 (W2008R2 Std, HP ML370 G6)
Download speed 0.19Mb/s, Up 6.43Mb/s, Ping 14ms
xxx.xxx.x.2 (W2008R2 Std, HP ML370 G6)
Download speed 0.21Mb/s, Up 6.68Mb/s, Ping 10ms
0
 
LVL 10

Expert Comment

by:rscottvan
ID: 33802268
Is your server in the same subnet as other windows computers?  If yes, have you compared results from speedtest.net on other PCs at the same time you're having trouble with the server?

What kind of switch is the server plugged into?  What else (firewall, router, etc.) is in the path between the server and the internet?
0
 

Author Comment

by:npcinfo
ID: 33806344
Hi scottvan

Many thanks for responding :) Yes all the servers and PC's are on the same subnet 255.255.255.0
Speedtest.net has the following results when run at same time as server, which is consistently poor whenever downloading from the internet.

PC running IE8 ping 14ms  UP 5.35Mb/s  4.63Mb/s Down time taken from start of test 37 seconds
Server running IE8 ping 15ms  UP 6.22Mb/s Down 0.18Mb/s time staken from start of test 2mins 50 seconds.
Not sure if this has any bearing whatso ever but have to click on compatibiity view to sometimes allow the graphic map to appear in speedtest on the server, the PC doesn't have this problem.
The switches of which there are 3 x HP Procurve 1800-24G 10/100/1000 cascaded together, I have enabled Jumbo frames on the switches to see if that made any difference to no effect.
I have in the past connected the server directly to the router and still got the same poor results. I have also replaced the NIC in the server, no change.

There is a SonicWall Pro 2040 Std firewall, and a systemone router provided and configured by Easynet, the connection is a surestream connection which takes 4 x 2Mb ADSL and aggregates them to provide higher bandwidth up to 8Mb.

Thanks
0
 
LVL 10

Expert Comment

by:rscottvan
ID: 33808292
I suspect one of a couple things:

1.  The mismatch between up and down speed makes me wonder about a NIC teaming issue.  What kind of server hardware, what kind of NIC/s, and how are they configured?

2.  A speed/duplex mismatch between the switch and server.  Check for errors on the switchport/s where the server plugs in.  If there are a lot of CRCs or collisions, this is almost certianly the issue.

If the issue is speed/duplex, you may have to experiment with settings a bit.  Start by pinning the switch port and the server port to 100Mbps/Full Duplex and see if the issue goes away.
0
 

Author Comment

by:npcinfo
ID: 33809137
1. The server is an HP ML370 G6 with an HP NC375i integrated Quad port multifunction Gigabit server adaptor, only one of the four ports are used as I had plenty of problems teaming. The other 3 ports are disabled, static IP address is assigned which I hope will now be stable as it falls into the excluded DHCP range and won't be grabbed by one of the older network printers as happened recently.

2. I will have to check next week when I am on-site (probably Tuesday) I will get back to you then.

Thanks very much
0
Why do Marketing keep bothering you?

Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

 
LVL 42

Expert Comment

by:kevinhsieh
ID: 33813142
I suggest breaking all of the NIC teams, delete all of the networking interfaces and let Windows redetect them. You will need to
reconfigure all of your networking. If that doesn't help, you can also reset all of your networking settings using the automated Microsoft fixit or the instructions at  

http://support.microsoft.com/kb/299357
0
 
LVL 1

Expert Comment

by:DA_Support
ID: 33824338
Hi there,

I guess you are running Standard Edition which only registers 32GB of ram.

Pull 4GB (depending on your DIMM config) to get it to 32GB or lower and test public downloading and let us know how you get on.

Cheers,
Doherty Associates
0
 

Author Comment

by:npcinfo
ID: 33838735
Having checked which port (19) the server was connected to I found it was set at 10MB Full duplex (10MB FDX) with barely any errors, so I played around changing the settings on the switch for the port speed tried all settings, they didn't make any difference. Anyway I left the swicth set to 100MB FDX over night and errors went through the roof. When onsite yesterday I also notice that xxx.xxx.x.28 had added itself back in to the IPv4 adddresses to the right of the .8 address, when viewed in the HP Network Configuration Utility (NCU) .28 is the IP address of an HP printer on the network. So I removed it again from the NCU, and having tried speedtest this morning still either get a test failure on download as its so slow or 0.1x download speed.

I have this morning added .28 as a reservation in the DHCP addresses.

The other thing I noticed is in the NCU as you can see from the screen shot seems to be saying the NIC is set to 1000MB (GB performance) should I have a go at adjusting this or will the switch take the responsibility for the network-server speed?

I am back on site later today so will try any further suggestions then.

Many thanks :)

Kevinhsieh - There is no teaming, thanks anyway (see earlier notes)
DA Support - I will see if there is any oportunity to take the server offline but as its a production server this may not be possible today. - Thanks
IP-change-screen-shot.doc
Port-19-stats-61010.doc
0
 
LVL 1

Expert Comment

by:DA_Support
ID: 33839561
Hi ncpinfo,

I understand that getting downtime on your production system is difficult.

We spent about a week of troubleshooting this exact same issue. Suspected NIC hardware offloading (TCP/IP Checksum & Flowcontrol), dupelex and everything else. Serriously we have taken boxes (HP DL380 G6 W2008R2std 36GB) with this exact same symptom (Slow public downloads (TCP only / not UDP) to the grave and back.

Bring ram down to 32 GB was the only fix for us.

If only ram was hot swap in DL3xx's :)

Hope this helps...
Doherty Associates
0
 
LVL 1

Expert Comment

by:DA_Support
ID: 33839637
Actually,

we had some issues with getting downtime on our production boxes too.

Our workaround was to install a Squid proxy server - i know this is left field but it was needed in our situation as these were part of a production Terminal Server Farm with users who always browse the internet.

Also it is worth noting that this issue does not only affect internet browsing. Any inbound TCP traffic that is not orriginating from the local subnet will be effected. eg Remote Desktop connections, or any SMB transfers over VPN conenctions.

Again,
Hope you find this info helpful.
Doherty Associates
0
 
LVL 1

Expert Comment

by:DA_Support
ID: 33839688
WRT your switching errors,

this is expected. you need to set both your switch and NIC settings identically ie 100-Full on both NIC and Switch if you are going to use manual. Having one of these set to Auto-Auto and one hard set will also cause duplex missmatch errors. If you were using one of the higher end swicthes you will see that duplex mismatch errors are logged as soon as the change was made.

My reccomendation is that you set both NIC & Switch to Auto-Auto. If this was a physical issue you would experience this symptom with local transfers too.

Also, it's worth nothing that we suspected the WAN provider for quite a while, infact right up until the point where we pulled the ram.

Cheers,
Doherty Associates
0
 
LVL 10

Expert Comment

by:rscottvan
ID: 33841032
As I said on 10/1, you need to have matching settings on the switch and server.  Set both to 100/full and it will solve this issue.
0
 
LVL 1

Accepted Solution

by:
DA_Support earned 500 total points
ID: 33883477
Hi There npcinfo,

Just wondering if you have had a chnace to pull the ram or resolve the issue though some other means?
0
 

Author Closing Comment

by:npcinfo
ID: 33883540
Hi DA Support, thanks so much for your help it was spot on. Do you know why?

Bug in MS OS?

rscottvan thanks to you too, need to create another question similar because I think you will have the answer to my other server(s) speed issue :)
0
 
LVL 1

Expert Comment

by:DA_Support
ID: 33883732
Hi Ncpinfo,

Glad to hear this was useful to you to - it was truly frustrating for us as I'm sure it was for you too.

We guess it is an MS bug but as you can imagine it is very diffucult to log with MS. Only thing that would help us narrow down further is if someone else could confirm the issues with non HP kit, we just don't have any kicking around with > 32GB ram.

I will use this thread to help show MS that this is a wider issues.

Thanks,
Doherty Associates.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now