Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 919
  • Last Modified:

IE 8 security

<script type="text/javascript" language="javascript"  src="file://D:\DevJava\FireFox\javascript\base_empty.js" ></SCRIPT>
IE8 won't allow loading local file execution when running from //localhost

IE 7 allowed adding "My computer" in zone 0; however IE 8 doesn't.  hence I need to know how to set the security.   I did add //localhost to trusted site; but, that doesn't fix it in IE8
0
intellias_net
Asked:
intellias_net
  • 3
2 Solutions
 
kawzakiCommented:
why not change the src to be relative to your html file it self ?

or if you have a local server (iis or apache) , use a local server link
http://localhost/foldername/page.html


anyhow, for per use,
If Internet Explorer restricts active content that you are sure you want to allow, click the Information bar, and then click Allow blocked content.


for permanent use,
add your site to trusted websites.

steps:

 To add a website to a security zone
Click to open Internet Explorer.

Navigate to the website that you want to add to a specific security zone.

Click the Tools button, and then click Internet Options.

Click the Security tab, and then click a security zone (Local intranet, Trusted sites, or Restricted sites).

Click Sites.

If you clicked Local intranet in step 4, click Advanced.

The website should be shown in the Add this website to the zone field. Click Add.

If the site is not a secure site (HTTPS), clear the Require server verification (https:) for all sites in this zone check box.

Click Close, and then click OK (or click OK twice if you clicked Local intranet in step 4).
0
 
Gurvinder Pal SinghCommented:
this path <<file://D:\DevJava\FireFox\javascript\base_empty.js>> is not from localhost, but from a location on system where the browser is running.

I dont think that browser can pick up the files from local machine, if the current domain is localhost or other wise. Means that if the web-page is being served by application server (remote or local) browser may not allow the file to be picked up from local system.


0
 
intellias_netAuthor Commented:
I'm running the application in local mode to debug it by selection of 'view in browser' mode from VS2008.    Although all applicaions are on drive D: along with include js files; howvere, the javascript source file are in one sub folder below the application test files,  I'm sure i could go 'relative' if the javascript files were above the test file sub folder; however, i've organized these test case in separate subfolders and having many copies of the source file would make maintennace a nightmare.  

This used to work in Win XP by setting the proper security.  

I'm sure using shortcuts to the javascript files won't work.

any suggestions would be helpful
0
 
intellias_netAuthor Commented:
it wasn't IE security anyway.
I didn't have "display script errors turned on' so the js file wouldn't load.
0
 
intellias_netAuthor Commented:
Gave me pause to investigate other approach.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now