Client computers can not access some websites.

I am having an issue where some client computers can not access random websites. Below is my DNS Setup.

Router: (DNS Enabled)
DNS1: 167.206.112.138
DNS2: 167.206.7.4

Server: (STATIC IP)
DNS1: 10.0.0.5 (Server IP Address)
DNS2: 10.0.0.1 (Router IP)

Clients: (DHCP from SBS08)
DNS1: 10.0.0.5
DNS2: NONE

Logically, this makes sense and appears to be the correct way the network should be set up. This morning, i did not have a DNS2 configured on the server. Once i added in the router a secondary DNS, the server was able to access the problematic websites. The clients are still unable. I have ran IPCONFIG/FLUSHDNS on the clients to no avail.

Any idears?
VCSLIAsked:
Who is Participating?
 
UbertamConnect With a Mentor Senior TechnicianCommented:
With SBS2003, there is a wizard that will automatically configure it.  I haven't run any wizards on SBS2008, as I just haven't had the opportunity to, but I imagine there should have been a step there that set the DNS forwarding.
0
 
UbertamSenior TechnicianCommented:
You need to set up DNS forwarders on the SBS server's DNS configuration utility.  Go to Administrative Tools | DNS and go to the properties of your server.  There should be a Forwarders tab.  That's where you'll set up your ISP's DNS or Google's DNS or OpenDNS or any mix of them.  167.206.112.138 and 167.206.7.4 to the list.  Your router's DNS doesn't matter since the SBS server and clients look to the SBS server for DNS resolution and they don't and shouldn't ever ask the router for DNS info.
0
 
UbertamSenior TechnicianCommented:
Furthermore, by having the SBS go directly to the ISP for DNS resolution, it is fewer requests.

How you have it now: Client -> Server -> Router -> ISP
How it should be: Client -> Server -> ISP

Shorter path, faster, and better.
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
VCSLIAuthor Commented:
Wow, what a wonderful person you are. THANK YOU!!!!

Why were these settings not automatically configured? Should they have been? Did i miss a step somewhere?
0
 
VCSLIAuthor Commented:
I just ran the "Connect to the Internet" wizard and it didn't ask for any sorta DNS info. It asked for the router and server IP and that was it. Weird because come to think of it, i think i remember seeing this at ome tine. There was also at one point the ability to set a DHCP scope in one of the Wizards. This has disapeared.

:(

Either way you're amazingness has solved my problem. Thank you!!!!

If you can think of a simple way to modify the DHCP scope please let me know.
0
 
VCSLIAuthor Commented:
Respondent was extremely knowledgeable and explained the information perfectly. Thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.