xxamp instalation

hi, im trying to make a website, but im totaly new; after few investigations i stoped at xxamp. i Downloaded and installed version 1.7.3 for windows. on the cmd.exe options i let the default ones. At the end i press 1 for starting control panel. then i try to start Apache and MySQL. Apache didnt start; in the lower window it shows Apache started but the green message "running" doesnt apear and the button is still "Start". MySQL is started and the message "running" its displayed. Next, im my IE7 when i type http:/localhost im redirected to IIE 7 page; when i type http:/localhost/phpmyadmin i get the rror message : "Server Error in Application "Default Web Site"" and "HTTP Error 404.3 - Not Found" and a bunch of stuff like:

Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and is not allowed.

Error Code: 0x80070032

Notification: ExecuteRequestHandler

Module: StaticFileModule

Requested URL: http://localhost/phpmyadmin/index.php 

Physical Path: C:\inetpub\wwwroot\phpmyadmin\index.php

Logon User: Anonymous

Logon Method: Anonymous

Handler: StaticFile


phpmyadmin folder is installed in c:\xxamp. shouldnt be in inetpub\wwwroot ?

any help in solving this installation issue is highly appreciated.

My machine is running Vista Home Edition, IE7
raulmondaAsked:
Who is Participating?
 
torimarConnect With a Mentor Commented:
The Apache service will refuse to start if it finds that port 80 is unavailable.
I agree with DaveBaldwin in that IIS (Internet Information Services) seems to be running on your system. Since that's the Windows webserver, it will have its grip on port 80.

Now there are three possible options on how to proceed:

1. You may not need IIS at all nor want to use it
Go to Control Panel > Programs > Turn Windows features on or off, expand "Internet Information Services" and remove the check mark from "World Wide Web Services" underneath it, or better: remove the check mark from IIS itself. Click Ok, let it remove the features, then reboot.

2. You want IIS to still run in times when you are _not_ running XAMPP
Before starting the XAMPP control panel, in a command window (Run > type: cmd and hit [ENTER]) type:
net stop WAS
hit Y to confirm and let it also stop W3SVC
Do _not_ reboot, but start Apache now via the XAMPP panel.

3. You want IIS and Apache to run simultaneously
Then you need to change the port that IIS web services are using from '80' to something like '81' or '8080', and also the HTTPS port from '443' to something else.
Check this post for how to do that: http://serverfault.com/questions/60285/how-can-i-start-xampp-and-stop-iis-on-port-no-80-in-windows-vista/60355#60355
0
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Did you reboot after installing XAMPP?  Also looks like you have IIS already running on that machine.  IIS and Apache can not both run on port 80, the normal web server port.  Put one of them on a different port.
0
 
torimarConnect With a Mentor Commented:
Addendum:

ad 1.) Here are some screenshots to guide you through: http://www.howtogeek.com/howto/windows-vista/how-to-install-iis-on-windows-vista/

ad 2.) After having finished using Apache in this scenario, you will want to restart IIS web services. Do this in a command windows via:
net start W3SVC
0
 
raulmondaAuthor Commented:
Thank you very much, indded once i stoped IIS 7. i have no problems with apache.

Sincerely,
Raul
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.