How to Disable "Delete Browsing History" in IE7 with Windows XP Service Pack 3 Installed

There are heaps of posts on the Internet with instructions to show how to disable "Delete Browsing History" in IE7. However it seems those instructions do not apply with Windows XP Service Pack 3.

Does anyone know how to solve this?

Thank you in advance
macgaAsked:
Who is Participating?
 
Tomas ValentaConnect With a Mentor IT ManagerCommented:
run command in MS knowledgebase on computer with Windows XP SP3:
regsvr32 %systemroot%\system32\ieaksie.dll
and then look in GroupPolicy editor if it helped you.
0
 
austchipmunkCommented:
you mean, you dont want to delete browsing history in ie7?

just go to tools, under internet options, at the general tab, uncheck delete browsing history on exit...
0
 
atuldelhiCommented:
The key is HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
Set a DWORD value named DisableDeleteBrowsingHistory to 1 in that.
You can also set that under HKEY_LOCAL_MACHINE to disable it for all users.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
Tomas ValentaIT ManagerCommented:
Try Group policy - Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Turn off "Delete Browser History" Funtionallity
or
HKLM\Software\Policies\Microsoft\Internet Explorer\Control Panel
Set a DWORD value named DisableDeleteBrowsingHistory to 1 in that.
0
 
austchipmunkCommented:
to run Group Policy management console:
Win+R || type GPEdit.msc in the box || OK button

Once there, you're looking for Administrative Templates in Computer and/or
User catagory.
Local Computer Policy || Computer Configuration || Administrative Templates
|| Windows Components || Internet Explorer || Internet Control Panel

and / or the same sequence except drill down on the User Configuration
branch.

Once there you will see that you can disable the various pages of the
Internet Control Panel. Between that and the multitude of options available
in the Security Page folder and the Advanced Page folder, you should be able
to configure as desired.
0
 
atuldelhiCommented:
Repeating the steps:

Click on START --> Run --> type regedit and do the below steps

The key is HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
Set a DWORD value named DisableDeleteBrowsingHistory to 1 in that.
You can also set that under HKEY_LOCAL_MACHINE to disable it for all users.
0
 
JamesSenior Cloud Infrastructure EngineerCommented:
Yes, this can be done via the registry. But, this would not be the best practice. For security reasons configurations should be done through Group Policy. Improper configuration of the registry can damage the system. Through Group Policy settings are centralised making this secure.
0
 
macgaAuthor Commented:
Thank you for everybody for your responses.
However, I followed the instructions from everyone and I seems
Group-Policy-Windows-XP-SP3.jpg
0
 
Tomas ValentaIT ManagerCommented:
this can solve your problem:
http://support.microsoft.com/kb/555218
0
 
macgaAuthor Commented:
Sorry about the last post...clicked the wrong button...

Thank you for everybody for your responses.

Unfortunately I followed the instructions from everyone, although I have no trouble locating those configurations mentioned in Regedit or GPEdit.msc with a Windows XP Service Pack 2 PC, but I cannot find them in Windows XP Service Pack 3.

I have attached screenshots of Regedit and GPEdit.msc, may be someone can let me what I am doing wrong.

Thank you in advance
Group-Policy-Windows-XP-SP3.jpg
HKEY-CURRENT-USER-Windows-XP-SP3.jpg
HKEY-LOCAL-MACHINE-Windows-XP-SP.jpg
0
 
macgaAuthor Commented:
You have nailed it Tominov... :o)

Just a note, you will need to restart the PC once the commands are entered. However even though both machines are identical in hardware / OS / configurations and etc. Tominov’s trick only worked for one machine, while the other one I had to follow the instructions mentioned in the link below, which I accidentally stumbled across. Odd but I guess that’s Windows for you...!!!

Either way Many Thanks

Link:

Internet Explorer Branch missing from some of the Group Policies


http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_21869695.html?sfQueryTermInfo=1+10+30+explor+group+internet+miss+polici
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.