Solved

Cannot Publish Exchange 2010 with Forefront TMG

Posted on 2010-09-24
5
1,335 Views
Last Modified: 2012-05-10
Hello,

I am trying to publish Exhcnage 2010 OWA using Forefront TMG. I have a Godaddy UCC cert in place and believe it is working as expected.

It seems that the rule I created in TMG is not being tested. If I go to Logs & Reports and start a query, I see Denied Connection from Rule: "Default rule". I do not see any logging before that. I assume I should see my rule "Exch-2010" in the real-time log? I have my rule positioned at the top (#1). I am not sure that this is the issue. It's just the only thing I'm noticing.

I believe I have everything else related to Exchange 2010 configured correctly. I can hit OWA from the inside. I am using basic authentication on the Exchange server and basic authentication on the Authentication Delegation tab in TMG.

Please let me know what additional information you need.

Thanks -Mark

0
Comment
Question by:mkueffner
  • 4
5 Comments
 
LVL 6

Expert Comment

by:Nagarajb
ID: 33753318
Hope all the things are followed , may be cross check/compare with the steps from below link.

http://www.isaserver.org/tutorials/Publishing-Outlook-Web-Access-Microsoft-Forefront-TMG.html
0
 

Author Comment

by:mkueffner
ID: 33753759
I stepped through the article and have verified that all steps have been followed with one exception: I imported the SSL certificate from the Exchange server. However, TMG shows the certificate as valid and the CN name matches my external DNS entry.
0
 

Author Comment

by:mkueffner
ID: 33753975
I ran BPA Tool. I am pasting the Publishing Failure error that seems to be the issue:

9/24/2010 9:45:11 AM - The Web publishing rule Exch-2010 failed because the Web listener selected for the rule is not valid. Verify that the Web listener specifies a valid IP address on this computer. I have two NICs: 10.1.10.14 and 192.168.1.154.

After seeing that error, I decided to add 10.1.10.14 to the listener even though I only have on IP addressed assigned on the NIC. When I added the IP address, I got a warning "The specified IP address does not belong to this netowrk. Do you still want to add this IP address he list of IP addresses specifed for this listener?"

I'm wondering if the External Network could somehow be tied to the wrong NIC?
0
 

Accepted Solution

by:
mkueffner earned 0 total points
ID: 33756781
The problem was I had the listener bound to the built in External Network. Binding the listener to the Perimeter network fixed the issue.
Thanks.
0
 

Author Closing Comment

by:mkueffner
ID: 34317119
I found that the listner was bound to the wrong network
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange 2016 Autodiscover error 401 unauthorized 28 43
exchange 2013 4 43
exchange, script 6 56
Exchange 2010 Unable to relay to outside domains 12 15
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now