[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Sonicwall dropping packets - cannot access youtube with a  connection reset

Posted on 2010-09-24
16
Medium Priority
?
7,557 Views
Last Modified: 2012-05-10
When trying to access www.youtube.com I receive "The connection was reset".  I am running a Pro2040.  When trying to access youtube outside of the firewall it works fine, so I know the problem is not my ISP.  Also, doing a DNS check from inside the network resolves the IP address.  I turned on Packet Capture, and i can see a dropped packet from my internal LAN IP to youtube.  This is happening across the LAN.  I don't know what to do from here.
0
Comment
Question by:danmcf321
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
16 Comments
 
LVL 20

Expert Comment

by:carlmd
ID: 33754913
Is anything posted in the Sonicwall logs when this happens. Do you have a similar problem with any other web site?

Also, try to ping the Sonicwall LAN interface from the PC in questions and see if you are getting any packet loss.
0
 
LVL 33

Expert Comment

by:digitap
ID: 33755620
additionally, do you have any of the Security Services licensed.  Possibly the IPS security service is blocking content.  Also, from the workstation you are testing from also login to the sonicwall console.  once you've logged onto the console, test youtube.  the sonicwall, by defualt, is configured to allow the workstation logged onto the console to bypass security services.
0
 
LVL 33

Expert Comment

by:digitap
ID: 33755625
forgot: you may alos add an IP exclusion within the IPS security service as a test.
0
Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

 

Author Comment

by:danmcf321
ID: 33755703
I was going down the IPS route.  In disabling IPS, the site worked properly.  The site is not accessible when i am logged into the admin console.  Nothing is being mentioned in the log files.  It's hard to test with the IP address, as it seems to change with DNS.  I can try to pinpoint that a little more.  The packet inspection mentions the following errors - DROPPED, Drop Code: 38, Module Id: 26.  
0
 
LVL 33

Expert Comment

by:digitap
ID: 33755768
Reviewing my drop codes, I don't see anything that makes a lot of sense.

http://www.fuzeqna.com/sonicwallkb/consumer/kbdetail.asp?kbid=7732

If you want to enable more logging, go to Log > Categories.  Make sure the level is Debug.  Then, you'll notice at the bottom several check boxes.  Click the check box at the top of each column to check all the boxes.  Then, go back to Log and access YouTube and see if something comes up.
0
 
LVL 33

Accepted Solution

by:
digitap earned 1500 total points
ID: 33755807
Also, review this.  It might be the content is Low Priority and you can allow that content, but log the activity.  Review this doc for steps:

http://www.fuzeqna.com/sonicwallkb/consumer/kbdetail.asp?kbid=6988
0
 

Author Comment

by:danmcf321
ID: 33755857
Logging is turned all the way up, and still nothing.  I added an IPS exclusion for class C network for youtube that it looked like it was cycling through.  It seems to work, but i'm not convinced that this will be a long term solution.  any other ideas?
0
 

Author Comment

by:danmcf321
ID: 33755978
Low Priority is not set to block.  i will do some investigating though.
0
 

Author Comment

by:danmcf321
ID: 33756089
I was able to get it to work.  I removed the IP level exclusion to the IPS software.  Then I went in to the Multimedia section, and went to the YouTube setting.  They were set to Default and were all low priority.  i manually set them all to "Disable" for blocking.   this seemed to work, but it doesn't make sense given that Low priority was not set to be enabled.  It's working now, so I guess there was an issue there...
0
 

Author Closing Comment

by:danmcf321
ID: 33756102
This put me on the right path to fixing the problem.
0
 
LVL 33

Expert Comment

by:digitap
ID: 33756206
yes, that is puzzling.  you set the global to allow, but it doesn't.  then you have to granularly set it to allow for youtube...hmmm.
0
 
LVL 33

Expert Comment

by:digitap
ID: 33756209
thanks for the points!
0
 

Author Comment

by:danmcf321
ID: 33756241
Yes - low priority attacks are not set to be prevented, and the youtube entries were considered low priority.  the manual override did it, but it doesn't make sense.  it also was not appearing in the event logs as an IPS block, which makes it even more werid
0
 
LVL 33

Expert Comment

by:digitap
ID: 33756250
are you up to date on the firmware?  it sounds like a bug.
0
 

Author Comment

by:danmcf321
ID: 33756297
We are a bit behind on the firmware, but have not seen too many issues like this.  We are in the process of migrating our VPN users to a new system.  Once that is done, I'll look into a firmware upgrade.
0
 
LVL 33

Expert Comment

by:digitap
ID: 33756802
please post back when you do...i'd be interested to know if the upgrade changes anything.
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question