Solved

VOIP over IPSEC VPN has no audio

Posted on 2010-09-24
4
2,551 Views
Last Modified: 2013-11-12
I have 2 pfsense firewalls with an IPSEC VPN between them.  everything seems to work fine except voip.  Sometimes I'll get two way audio, but generally its silent on both ends.  What's odd is that if I reset firewall states, or change settings and apply them, i can usually get the first call I try to work.  After that, it goes back to no audio.  

Here's the layout:

phones (192.168.10.0/24)  >>  pfsense  >>  VPN  >>  pfsense  >>  (192.168.0.0/24) asterisk

Phones are registering to the local IP of the PBX (192.168.0.25) just fine.  I do not have any static routes.  Automatic NAT is on (for ipsec passthrough).  All ports are open properly to my SIP trunks.  Any ideas?
0
Comment
Question by:lorsungcu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 7

Expert Comment

by:namol
ID: 33753900
can we see your sip_nat.conf file and any logs so we can attempt to troubleshoot? Shooting from the hip I'd say one of the phones is sending some of the traffic to the internet after it makes a connection.
0
 
LVL 2

Author Comment

by:lorsungcu
ID: 33753933
I'd love to give you my sip_nat.conf file, but we're using Switchvox, which gives you no access to configuration files.  Also, as this should be all over the VPN, NAT shouldn't be an issue.  If it helps, I can take screenshots of my pfsense configuration.
0
 
LVL 2

Author Comment

by:lorsungcu
ID: 33754039
When I make a call, these are the states the firewall has for the phone:
Proto   	Source -> Router -> Destination   	State   	
udp	192.168.10.199:5060 -> 192.168.0.25:5060	MULTIPLE:MULTIPLE	
udp	192.168.0.25:5060 <- 192.168.10.199:5060	MULTIPLE:MULTIPLE	
udp	192.168.1.1:123 <- 192.168.10.199:1074	NO_TRAFFIC:SINGLE	
udp	192.168.10.199:1074 -> 173.165.229.145:5945 -> 192.168.1.1:123	SINGLE:NO_TRAFFIC	
udp	192.168.0.25:55244 <- 192.168.10.199:2250	NO_TRAFFIC:SINGLE	
udp	192.168.10.199:2250 -> 192.168.0.25:55244	SINGLE:NO_TRAFFIC	
udp	192.168.0.25:55245 <- 192.168.10.199:2251	NO_TRAFFIC:SINGLE	
udp	192.168.10.199:2251 -> 192.168.0.25:55245	SINGLE:NO_TRAFFIC

Open in new window

0
 
LVL 2

Accepted Solution

by:
lorsungcu earned 0 total points
ID: 33754820
I had 1:1 NAT for the PBX, with firewall rules deciding where things can go, but apparently that wasn't enough.  I added NAT entries for RTP ports, and everything works.  Not sure I get that, but I'll take it.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question