Solved

Exchange 2003: Send local email to external SMTP server

Posted on 2010-09-24
5
441 Views
Last Modified: 2012-05-10
Hi everyone,

I'm migrating to Google Apps (slowly) from Exchange 2003.  I have a problem where the new Google Apps users are not receiving email sent from Exchange users.  I pretty sure this is because Exchange is not sending the email to my ISPs SMTP server like it does for external email.  How can I force Exchange to send all email to my ISPs SMTP (even local email)?

Thanks.
0
Comment
Question by:ragetech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 12

Expert Comment

by:FDiskWizard
ID: 33756340
So you're using a shared namespace; like myusers@contoso.com?
Check out this article on shared namespaces:
http://www.msexchange.org/tutorials/Exchange-2003-SMTP-Namespace-Sharing.html
0
 

Author Comment

by:ragetech
ID: 33756770
Thanks for the link.  I updated my Recipient Policies as suggest (setting the .local to primary) and unchecking the real domain.  However the system still sends real domain email (for my domain) without going to the SMTP server.  Although my from address now reads .local (but the to address is correct).  Out of domain email still sends correctly.

0
 
LVL 12

Expert Comment

by:FDiskWizard
ID: 33757219
We have our recipient policy like this, where SharedDomain.com is shared... I recall your issues when we first went to 2003 :)

NAME                           Priority  
Site-name                   HIGHEST
Sharedomain.com              1
AltDomainForUs.com          2
DefaultPolicy                    Lowest

I don't know that anything else needs setting up, besides your Internet Connector.
Does Google now control your MX record? Do both places get email from outside currently?



And I'm not sure about how your incoming mail is working....

0
 

Author Comment

by:ragetech
ID: 33757270
The MX record does point to Google, however Google is configured to relay unknown addresses to my Exchange.  My hope was I could add users as I migrate them to Google.

I only have a DefaultPolicy in my Recipient Policy.  I will try creating one for my domain specifically.

0
 

Accepted Solution

by:
ragetech earned 0 total points
ID: 33774108
I contact MS support ($99 for an email in 24 hours -- Experts-Exchange is the way to go) and was told that MS Exchange 2003 does not do what I want to do.  Even with the Shared Domain configuration the system would only forward emails for accounts it does not know about.

I have reconfigured my MX records to point back to my Exchange server first and have configured forwarding addresses for each user as I migrate them to Google Apps.  Once all the users are in Google Apps I will switch my MX records to Google.

In case anyone is interested, Exchange 2007/2010 does support what I want to do.

Thanks for all the ideas.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question