troubleshooting Question

Apache 2.2.9 on SLES 10.3 cannot load mod_speling as a shared object

Avatar of majorwoody
majorwoody asked on
Linux OS DevApache Web Server
2 Comments1 Solution730 ViewsLast Modified:
I'm trying to load this mod dynamically the same way we load our weblogic proxy plugin in the Load Module section of my main .conf file and its not working.  We have dozens of Apache servers and don't want to recompile.

I compiled a new Apache instance on a server that is exactly the same with mod_speling as a DSO and then copied that .so file to my server.

I figure I should see a line in the error.log when it loads the module successfully just like for the weblogic plugin but it does not.

This is what I have in my main httpd.conf
LoadModule speling_module /modules/mod_speling.so

CheckCaseOnly On


In my vhost.d I have another conf with the following:

<IfModule mod_speling.c>
      CheckCaseOnly On
  </IfModule>


I'm only interested in correcting capitalization differences and mainly file names.  My idiot users refuse to use lower case only when publishing pdfs through our content management app and then are inconsistent with the links.  These files are spread out in more than 20 different directories at various levels under the docroot.

I get a 404 when testing.

I also tried compiling with apxs with the same result unfortunately.




LoadModule speling_module /modules/mod_speling.so

CheckCaseOnly On
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 2 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 2 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros